Sound issues

I installed the latest nightly build (23 January).

When booting, there’s an annoying high pitch sound which lasts for a few seconds.

I muted all controls in mixer settings but for some reason nothing is saved,
neither between reboots, nor even between open/close of Media preferences window.

Is there any way to turn off the media server?


you could stop the media server process from the process controller that lives near the clock. don’t know why haiku would make such a sound. What are you running haiku on?

Is there any way to turn off the media server?

If you don’t find a real solution, you could also find the line “launch $SERVERS/media_server” in /boot/system/boot/Bootscript and comment it out (#) and then start it by hand after the boot has completed. Maybe putting a link to media_server into ~/config/boot/launch/ will delay its start enough to avoid the screeching.
If that delayed start isn’t enough, put a “sleep 3” and “launch $SERVERS/media_server” into ~/config/boot/UserBootscript to wait another 3 seconds before launching the server.



i installed last week another nightly build and that sound during boot is gone.
i run haiku on a Thinkpad T61p laptop.