[SOLVED] Where is haiku-anyboot.image?

I would like to install Haiku to an empty partition using the technique described at https://www.haiku-os.org/guides/installing_haiku_image_disk_partition

However, it calls for starting with haiku-anyboot.image which I have not been able to find. The download page did not offer that format. Please tell me where I can find it.

I will mention that I burned the download .iso, but my comupter would not boot it. It just ignored ht eDVD and went right to the GRUB menu. I have installed many Linux systems from DVD, so there must be something different about the Haiku DVD that my PC doen’t like.


The zips offered at Get-Haiku contain anyboot images. The hint is in the filenames: haiku-r1beta1-x86_gcc2_hybrid-anyboot.zip :slight_smile:

I expect, you did unpack the zip and burned the actual ISO. And made sure the boot order in you BIOS tries the CD drive first.
I don’t have a concrete idea what might have gone wrong… Personally, I prefer to create a USB stick for installation.

Thanks for the suggestions. To give a better description of my problem. The linked page says to execute the following:

dd if=haiku-anyboot.image of=haiku.raw bs=1M skip=$(expr $(od -j 454 -N4 -i -A n haiku-anyboot.image) / 2048)

dd if=/dev/zero of=haiku.raw bs=1 seek=506 count=4 conv=notrunc

So I need to start with haiku-anyboot.image, and the Get-Haiku zip has only haiku-release-anyboot.iso and ReadMe.md. Hence my question about getting the .image file.


It doesn’t matter if it’s an image or an iso.

Just don’t pay attention to the extention, whether it’s " .image " or " .iso " the same method can be applied for both cases.

Thanks! Changing .image to .iso got me through the whole process until it came time to add the Haiku parition to the GRUB menu. update-grub didn’t detect the partition.

The instructions say to consult the GRUB2 manual for how to chain load, and a broken link is provided. I googled to the correct location and found this:

5.1.2 Chain-loading an OS
Operating systems that do not support Multiboot and do not have specific support in GRUB (specific support is available for Linux, FreeBSD, NetBSD and OpenBSD) must be chain-loaded, which involves loading another boot loader and jumping to it in real mode.

The chainloader command (see chainloader) is used to set this up. It is normally also necessary to load some GRUB modules and set the appropriate root device. Putting this together, we get something like this, for a Windows system on the first partition of the first hard disk:

menuentry “Windows” {
insmod chain
insmod ntfs
set root=(hd0,1)
chainloader +1

I’m thinking this might be the correct stanza for my system where Haiku is on sda8:
menuentry “Haiku” {
insmod chain
insmod eb
set root=“hd0,msdos8)”
chainloader +1

I tried to make the syntax match entries in my current grub.cfg. I used “eb” because of this line from the instructions:

Optionally, you should set the partition type using fdisk. The partition type for Haiku’s BFS file system should be set to “eb”.

I don’t know how to do that, and Google did not provide what I needed.

I’m going to give the above a try, and here’s hoping!


Success! The Haiku entry showed up in the GRUB menu. When I selected it, there was an error message, but it went away before I could read it (my 80-year-old eyes are pretty bad). But then the Haiku screen came up, and I was able to explore the desktop. I chose not to install then, because I need to find out what that does to my hard drive (which has four other working systems on it.

Thanks again, guys, for all the help.


Well, Haiku is already installed on your hard drive, it’s just constrained in the partition size of the original image. To make some place, you can delete the provided source packages, they are useless.