[Solved] Updated haiku and now can't boot anymore

I did perform an update using Software Updater and now Haiku Loader doesn’t find the boot partition anymore (the logs say something about being able to find the partition but being unable to scan it).

Is there a way I can fix the situation without reinstalling from scratch? I had started using haiku daily and it would be frustrating to lose the data that I had there.

That’s strange.
You can try to boot from a previous state by pressing space bar or shift key during boot, you will then enter Haiku boot menu and there you can select a previous stage.

If you’re using EUFI, try copying the EFI boot file from the Beta 4 install media to where you have it on your computer.

Which one is the EFI boot file? The only two files I can find are “esp.image” and “haiku-boot-floppy.image” on the Beta 4 install media.

Mount the EFI partition on the Beta 4 USB media (if you’re using USB). It’s the smaller one. I don’t remember what it’s called. Inside there, there should be a folder called EFI or similar. Copy that to your EFI partition on your computer.

Actually the problem is exactly that it doesn’t find any boot partition the loader, so there are no previous states I can select.

I did copy the BOOTX64.EFI file from the USB Image to my EFI partition replacing the existing one, if that was what you were suggeting it didn’t change much. It still gets to the loader complaining that it can’t find any boot partition.

Dang. I seemingly had the same problem you did, and after copying that I was able to boot again. Well, it was worth a try.

Sorry my fault, I was on windows and issued the xcopy command from the wrong path. I noticed because I had two BOOTX64.EFI files in my EFI partition… I deleted both and placed only the one from the USB media and it booted correctly.

Thanks for the help!


I ran software updater and hit a few weird issues recently. Need to reinstall beta 4 to try and find proper reproduction steps, but I lost a bunch of installed packages (i.e. they didn’t get mounted at least, and were no longer in the menu), including the developer packages that were installed originally, Vision and Epiphany. Weirdly some others like Yab didn’t disappear.

Also seem to be in a weird situation where Hiaku randomly fails to boot, but a restart usually sorts it. The one time I tried with debug logs on it stopped at the first page but wouldn’t accept any keyboard input to let me continue.

When I’ve got more time on my hands will try and nail down some reproduction steps.

Same issue here in x64 latest nightly update, but not with UEFI. Any idea how to solve it?

Unfortunately, no. I haven’t dealt with BIOS computers in quite a long time :slightly_frowning_face:

The only thing I can think of, is to boot using the Beta 4 ISO and see if there’s a way to re-write the MBR? I don’t know if that would do anything or not, though, but it’s all I got.