[SOLVED] Share Keyboard+Mouse between 2 computers(Haiku-Win) through KM Switch

Good day,

Today I went back to the old setting at work, Windows Box and Haiku Box, sharing keyboard and mouse through a KM (keyboard+mouse) switch. Well, it does not work yet (ticketed already, which was duplicate of an older one).

If I switch from Haiku to Win then there is no way back to Haiku :cry:
So I have to turn off Haiku box, and then back on to use Haiku. Means can´t use both boxes at same time. Damn :grimacing:

Guess will have to wait for tickets to find solution.

Regards,
RR

Not same but yes related: some days ago, i added a pull request to add synergy to haikuports:

With this; you dont need the switch, only need the machines in the same network.

@nhtello, nice work there!
I presume that software needs to be installed both on the Win box and on the Haiku box in order for it to properly work. If that is so, it’s a no go. The Win box is “locked” to only certain software :wink:

Nonetheless, I’m not very fond of this kind of software. I’m very old fashioned and like hardware stuff better than software :slight_smile: Even don’t like so much wireless keyboards.

I have all pc wired, and never use wireless but for laptops or phones, and at that moment, it’s turned on. It’s off the rest of the time. :smiley:

Regards,
RR

hehe! totally understand you! Yes, this soft need a computer acting as server (keyboard and mouse connected) and a client.

lucky with those tikcets!!! :smiley:

There is also


And
https://github.com/kallisti5/synergy-haiku
And also

Hey I know this icon :wink:

1 Like

Good day,

Thanks for the tip @Munchausen. I just installed barrier (not that I like this procedure though), and it does work on Haiku and Windows. Keymap is messed though. So need to figure out how to fix it…

Seems in my case I have to modify the config file to this: (shared with windows) Ah, and mousewheel has its own… behavior…:rofl::rofl::rofl:

 enable = true
 server = 192.168.1.101
 server_keymap = "AT"

So it seems that this is the only way to go for now if I want to use Haiku at office without hitting the power button each time I switch. Thanks for the links.

(hope the ticket gets solved though :slightly_smiling_face: as I rather use physical than logical stuff for peripherals as these)

Regards,
RR

This issue may depend on your KVM box.There may be something on the Haiku computer preventing the KVM from switching to it, but to me that seems more like a KVM issue than a Haiku issue, because normally they just switch at the hardware level.

Good day,

It might be the KM switch, though I presume not likely. The switch works fine with any os but Haiku. Tried with Win and different Linuxes without issues, it´s just Haiku who complains (there´s already a ticket about it).

Regarding Barrier, it seems to work but the mouse wheel, which does not scroll on Haiku. I´m not very fond of this kind of software, but for now it´s the only option I have to be able to use Haiku without turning on and off the computer all the time.

Regards,
RR

Good day,

Looks like it’s a nope. Barrier causes lots of troubles causing system lock up, and can’t type certain characters when working. Therefore, removed for now.

While the KM ticket is not solved I will just unplug, and plug the keyboard/mouse remote on each box. Seems like the best solution at the moment.

Regards, and Thanks all.
RR

Good day,

Looks like besides a crash course on C++ injected directly to brain I’m going to need a brain transplant.

Today I just got a new KM Switch to try out, as @ComputeWorldwide pointed out, and I was facing same situation. Sometimes it worked, sometimes it didn’t. Then, in a sudden wrath of inspiration, I checked which USB port the KM switch was plugged into. Well, it was one of the 3.0 ports. So, I changed the switch to the USB 2.0 port and then… works… at least for the past hour I’ve been able to switch from Win to Haiku and viceversa without issues… :joy::joy::joy:

How’bout that!?

Let’s see if tomorrow it still holds, then we can set this topic as solved when using USB 2.0 ports.

Thanks you all, and Regards,
RR

2 Likes

Good day,

Well, it seems that the issue was the USB 3.0. Using the USB 2.0 port it’s working fine again today. Therefore, I set the topic as SOLVED.

Remember, anyone, don’t fall in the same mistake I made. In order to share keyboard and mouse between Haiku and other OS through a KM switch (hardware), do plug the switch to the USB 2.0 port (at least for now) of the Haiku PC.

I’ll modify the ticket accordingly too. Apologies to the devs.

Regards,
RR

3 Likes

That’s why I still use PS/2 stuff :smiley: