[SOLVED] Problem compiling RTL81xx ethernet driver


I’m trying to compile the RTL81xx driver, as I installed Haiku yesterday (18th January nightly build) on my Dell Mini 10v, and I ran into this bug.
I want to compile only the driver and its dependencies, since it would take a while to compile haiku on a 1.6GHz Atom :slight_smile:

ar: creating generated/objects/haiku_host/x86/release/tools/rc/librdef.a
ar: unable to rename 'generated/objects/haiku_host/x86/release/tools/rc/librdef.a'; reason: Invalid Argument
rm -f generated/objects/haiku_host/x86/release/tools/rc/librdef.a
ar  ru generated/objects/haiku_host/x86/release/tools/rc/librdef.a 
...failed Archive generated/objects/haiku_host/x86/release/tools/rc/librdef.a ...
...removing generated/objects/haiku_host/x86/release/tools/rc/librdef.a
...skipped rc for lack of librdef.a...
...skipped rtl81xx for lack of mimeset...

whole output at pastebin.

I’m trying to build build it on my Haiku install. It’s a bit strange that it tries to rename librdef.a, an then deletes it, but I’m not familiar with jam :slight_smile:

thanks for the help.

Try without -q and hopefully get more information for the error. I could not tell why that was happening from your output.

You can also change into a specific directory and type jam which will compile everything in there. You should do this for tools directory to see if that builds them without errors.

Yes, I mentioned to Layton to report that bug. My Haiku system is packed away so I cannot provide you with an updated binary driver but maybe Layton will do it for you. Look for his thread here & post to it asking. Otherwise, you’ll either have to compile the driver yourself or wait for a developer to update the rtl81xx driver with the latest.

Thanks for your help. I managed to build the driver. It looks like the problem was that I was trying to build it on a vfat partition, not bfs. my driver works now! (dhcp doesn’t but that’s a different story :))

Great to hear that. Building on vfat partition is not supported as you found out. In addition to BFS, you can build on Linux filesystems.

I build Haiku on ext3 filesystem without xattr (extended file attributes). This will help you choose filesystem if you want to build on Linux. Best to use one that supports xattr.


thanks for the info. i only used vfat to transfer sources from linux to haiku since i didn’t have the network driver working there :slight_smile: