[Solved] Install and network problem

Bonjour, je vais écrire en français pour ce problème sinon cela risque d’être compliqué dans ma traduction xD

Je suis entrain d’essayer d’installer HAIKU R1A2 sur un Pentium II.

C’est là qu’est le problème. Pendant l’installation il y a une erreur au paquet 786 (pour le webpositive)
Et je ne sais pas pourquoi et comment le résoudre.
Ce n’est pas une erreur de gravure du cd car je l’ai déjà utilisé pour un autre pc.

J’ai trouvé une résolution de ce problème mais un autre problème vient à ce moment.
Voir le lien pour l’explication de la solution :

Je ne parviens pas à avoir une connexion, je suis branché en Ethernet sur ma Box, dans l’onglet network du desktop il y écris pourtant que je suis branché quoi.
J’ai essayé de ping mon autre pc ou ma box mais rien n’y fait.

Donc voilà, si vous avez besoin de plus d’explication je veux bien vous les fournir, et si je dois écrire en anglais je veux bien essayer x)



May I suggest you to try with an Alpha 3 Release Candidate image? (http://haiku-files.org/cd/)

Alternatively you could wait for the actual Alpha 3 to be released.

PS: Sorry for not answering you in French, my French is way too rusty to be understood.

Alpha 2 is very old. Very soon will have Alpha 3. Should happen in about 1 to 4 weeks. You can either wait for Alpha 3 or use a newer nightly image from here:

Some network cards are not supported in Haiku. Not sure if there is a driver for your card without more info. Newer Haiku will have better chance to support your card. Try nightly image.

Also, go into terminal and type listdev. I need to see the information for your network card only which shows as 3 lines. I need to see the two full lines with vendor & device. Then I can give you better help.

PS: Sorry for not answering you in French, my French is way too rusty to be understood.[/quote]

No problem, it’s not a big problem to read english, but write is harder xD

Thx for your answer, i look to test tomorrow

I have test with the last version =D
Run perfectly and install successful

But the network don’t work 8/

thx guys

If you go into Preferences->Network do you have a network driver listed in there? If yes, which one?

Start terminal program, type listdev and post the output for network card here. It should look like this:

device Network controller (Ethernet controller) [2|0|0]
vendor 8086: Intel Corporation
device 100e: 82540EM Gigabit Ethernet Controller

The first line is not important but the 2nd and 3rd are. If you give that then I can see what network card you have to see if Haiku has a driver for it.


It give me this :

~/Desktop> listdev

device Network controller (Ethernet controller) [2|0|0]
vendor 10b7: 3Com Corporation
device 9050: 3c905 100BaseTX [Boomerang]

I search why my gcc don’t work in Haiku, but it’s an other story xD
in the good directory :

~/Desktop> gcc -o test test.cpp
gcc: test.cpp: No such file or directory
gcc: No input files

But i have develop in Windows and Ubuntu and it’s the same command line no ?

gcc is the same as Linux. The error is saying it cannot find test.cpp. You should have test.cpp in same folder (or specify path to it). ie, error - gcc: test.cpp - no such file (or folder).

I checked and Haiku has 3com driver which supports your network card. I ran recent nightly in VirtualBox and see the 3com driver inside of Haiku.

From Haiku source:

Card Device ID 0x9050

Your network card, according to 3com driver,
TC_VENDORID, TC_DEVICEID_BOOMERANG_10_100BT, “3Com 3c905-TX Fast Etherlink XL”


Can you check Preferences->Network to see if the 3com driver loaded for you? It will be listed under Adapter. What do you see there? listdev only tells me the hardware in your computer but not if any drivers have loaded for your hardware.

If 3com shows up Network Preferences then you have network settings issue. If 3com does not show up in Network Preferences then you have a driver not loading issue.

Omg ! Guys
I don’t understand my computer oO
I have run it and for fun i launch Webpositive and the web run
I have change nothing xD

But thx you, to want to help me, all run perfectly now =)

I still have to test the build with gcc. =)

Edit : I’m not stupid no ?


There’s no test.cpp in your file listing.

Ohhhhhh okkkk, i found the solution, I thought when i make a “C++ Source” the file have the good extension, but i see i must add .cpp at the file
-_- xD Stupid, but I don’t usually.

Thx, it’s ok, all run now :slight_smile:

Very fine community

Ok, great to hear. Now you should be able to enjoy the OS. Later,