[solved] Help solve my unbootable installation woes?

Hiya… first of all, amazing work to all the devs and contributors of other work… I loved BeOS in the late 90s, and while i’ve checked in with Haiku over the years it seems its now at a state that I can actually use and have fun with on a second ‘dev’ machine here. Awesome work.

Now for the puzzling part, i’ll try and be brief… (EDIT: guess i massively failed in that endeavour)

I successfully installed Haiku the other day on an old 30gb (yes 30gb, lol) SSD I had laying around, just to try it out. This is on an old AMD Athlon II X2 220 system, with 8gb ram. I’ll be using this mostly to play with Haiku, and also as a serial monitor for Amiga dev hardware work over a null modem cable. Everything went swimmingly. Even falkon played nice most of the time.

I decided I would do the system over with a 120gb SSD, so I could perhaps dual-boot ReactOS and AROS and the like to try other hobby OS’s at a later stage. Note that all other specs are the same, and none of these other systems are installed.

The SSD in question was picked up second hand - CeX (UK second hand store) failed to wipe the disk of the previous users data, which is crazy to me, but it had a previous Windows installation. I wiped it with diskpart on another system using the ‘clean’ command before continuing.

Installation is fine, but now I get the dreaded ‘stage1: failed to load OS’ message. Things I made sure I did are:

  • Initialised the disk with ‘Intel Partition Table’ in the disk-setup-thingy
  • Made the partition Active in the Haiku disk-setup-whatsit
  • Formatted to Be filesystem.

Things I have also tried after searching around:

  • writembr to the raw disk dev
  • makebootable to the Haiku partition (thought it was worth a try)
  • Shouting
  • Some UEFI boot manager setup tutorial I was following before realising the board is of course not UEFI
  • Swearing

I have even tried starting everything from scratch… re-‘cleaning’ the drive, even re-writing the USB flash. The only thing i’m doing differently to the install on the other SSD (which is no longer in the sytem btw), is to install to a 30GB partition, rather than the full disk.

I have a feeling this all may be something to do with the previous owners installation of Windows on the new SSD, and perhaps i’m missing something obvious?

Any help would be appreciated…

Many thanks and again, awesome work!


Hi PeterW… I get the

“bios_ia32 stage1: Failed to load OS”


Weirdly, i’ve just now repeated the whole process, but this time I decided I would format the whole drive with the Be filesystem, then go back and create the partition table etc etc, and then it gave a ‘No sys loader!’ error…

Even weirder is I booted back into USB flash, and in DriveSetup it shows the disk as not formatted (despite having just ‘successfully’ completed the install onto it), and also shows it as only 7.5 gig instead of 30gb.

I’m just about to go through the process again… initialise the disk, create the partitions and install, and I guess we’ll see what happens then.

The silver lining here is that Haiku is so quick installing that all of this takes just a few minutes.

Maybe I’m a bit confused today. But I couldn’t find info what bootloader you try to use.

Oh its more likely I’ve just not given the information, lol.

Okay so i’m not actually sure how to answer that. I’m now just following the standard install instructions. The stuff about ‘Boot Manager’ from my first post was a sort of desperate attempt to try something different.

So i’m just going into the USB boot, and doing everything as per the haiku-os.org installation instructions.

Its as if something screwey has happened to the boot record that Haiku isn’t 100% wiping when I set it up or something? The full error on boot is…

‘bios_ia32 stage1: Failed to load OS. Press any key to reboot…’

But for the life of me I cannot find the ‘any’ key.

I’ve just this minute confirmed that the old 30GB SSD i had previously installed to still boots just fine. Weird!

Maybe I need to use some other tool to like, completely wipe the new SSD, boot record and all, and stard again.

Haha, that’s a quote of Homer…

I thought I know something about the BIOS boot process and partitioning. But I can’t understand that is is unformatted after the installation. That just seems like a bug.

Maybe not partitioning but rather using the whole disk is the solution? Because you said that’s the only difference.

I’m gunna look into using some other partition-magic-like tool to see whats actually going on with the SSD partition tables. I’ll make a record of what Haiku tells me for comparison. If there really is a bug here I guess it’d be worth documenting.

Haha, yeah. Gotta see the funny side in these kinds of things!

Yeah just tried that now…Haiku (the USB boot disk) DriveSetup now reports the correct 111.79GB single partition, and that it is Active, but still no luck getting it to boot. The same bios_ia32 error again. I’m gunna screenshot DriveSetup now, and then install some other partition management tool to a USB stick and take a look.

I’ll update when I can, but i’m gunna go eat shortly so it might be a while.

Cheers again!

I’ve found some info that some users have defect MBR because the system doesn’t write the same way onto SSD as onto HD.

All sorted!

I used a GParted-Live USB to re-initialize the disk.

First I did it to ‘GPT’, and installed Haiku to a new partition. This didn’t work either, giving a never-ending flashing cursor on boot.

I then realised that the official instructions call for ‘Intel Partition Table’, so I went back into the Haiku USB and used DriveSetup to re-initialise the disk. This time it all worked swimmingly.

It’s worth noting that in GParted the Haiku partition showed as ‘unknown/unformatted’ but this could be a limitation in what GParted can recognise i guess.

I think ultimately something screwy was happening with the partition table or MBR that Haiku just couldn’t/wouldn’t erase. I wish I could provide more data to help debugging, really.

Cheers again