(solved) Dosbox configuration File not update dosbox

I have installed Dosbox but the configuration file in boot/home/config/settings/dosbox> not update the Dosbox config now. It worked few days ago but not now. (I have done a pkgman update it is the trouble?)

–Solved it–

I solve it by the command in Dosbox:
config writeconf dosbox.conf

That create a new configuration file for Dosbox in /boot/home
Dosbox now use it by default…Curious.


Thanks @kitsune64 for solving a problem I was pulling my hair out over

For those who are trying to replicate this fix - I had to type a switch for the wite command, and the full path to the file in Haiku, eg:

config -writeconf /boot/home/config/settings/dosbox/dosbox.conf


1 Like

Okay - I jumped the gun - Dosbox indeed writes the default config file when you issue that command, but it does not seem to automatically read this file in on launch - I updated it with mounts, and it seems to ignore my updates on launch. If I type the command, it over-writes the file with the default (no real surprise there).

Does anyone know how to make DOSbox read and utilise the config file?

Do you launch Dosbox everytime the same way?
I mean, do you click on the menu icon or, do you open a terminal and type dosbox there?
IIRC, there’s a problem with environment variables that are not always set and results could be different. Checking both could worth the try.
If the problem comes from that, feel free to vote for the relative ticket.
If you use Dosbox often for the same purpose, writing a shell script to launch it could also help.

1 Like

Update - if I don’t specify a path to save the config file into (and let it dump it in /boot/home) it works if launched from Deskbar… (shortcut → QuickLaunch does not work… I have upvoted the env related bugs :slight_smile:

1 Like