Software vanished after reboot

I use Haiku beta 2 directly on my Asus laptop. When using Haiku depot and installing any software, I got the notice that I have to reboot to make the software work. This comes after installing any software from the Depot.
Normally after a reboot all is fine. But now I installed Aqemu with Depot and after this notice and a reboot the software doesn’t start.
Before a reboot Aqemu is listed in the Deskbar menu. After the reboot it is not listed anymore. I found the Aqemu.hpkg in the settings folder and the qemu hpkg as well.
When using the terminal it says:
aqemu => not found
Qemu works from the terminal, but very, very slow.
This all aonly happens in my real installation on my laptop. In my virtualbox Haiku this never happens. I never have to reboot after installing a software and even Aqemu works.
Both are the same Haiku beta2 iso’s.
The laptop is able to work with virtualisation. I often use virtualbox or qemu(kvm). They normally work very fast on my machine. For longer time I used Quebes OS which uses Xen.
Afterall I tried to install Q4OS (Debian Linux), an lightweight Linux. It worked poorely slow. It need 15 minutes for 1 % intstalling. I cancled this installation.

Which hrev do you use? Do you use Beta2 with no Updates? If so I would advice you to Update. From Terminal: pkgman update
or use SoftwareUpdater to do so.
64bit or 32bit?
Try to double click on the Aqemu.hpkg

As I wrote I use the beta 2. Of course with all updates. There are no other updates available. I use 64 bit.
In /system/apps there is no aqemu listed
In /system/settings I find the aqemu.hpkg. A double click leads to Heiko depot. There is a button to start the app. But with clicking nothing happens.

Because there was a problem with the last 64bit hrev 54968 which could not be updated anymore.

This should never happen. Are you sure about the path? All .hpkg packages should live in /system/packages.

Also Haiku doesn’t have kvm or any other hardware virtualization drivers so it is expected to be that slow for modern OS unfortunately.

This should only apply to nightly images.

@muffin, if you changed over to the nightly channels you might be impacted by this.

To help us debug:
Give us a screenshot of the about window.
Give us the output of pkgman list-repo

To try and solve the issue:
Reboot, enter the bootloader menu (tap space before the icons show up)
Select a “previous package activation state”

Once Haiku loads, run an update again and see if that fixes it. is the bug @brunobastardi is talking about.

1 Like

You’re right. I was sitting on another machine when writing my post. My mistake. The packages are all in the folder packages. Including Aqemu. But it doesn’t start.

I now try to reboot a prior state.

Edit 07:15 pm:
I could boot to a state from yesterday and now Aqemu is in the menu and starts normal. For testing reasons I installed a fresh Haiku beta 2 on another USB stick. I made al updates and then installed Aqemu. I got the same problem. I had to reboot after the system notice and then Aqemu was vanished again.
Before the reboot I found it in /system/apps and it looks like a normal app like all other else too.
After the reboot the icon in /system/apps has changed - only for Aqemu. It looks different than all other apps.
On my original Haiku stick there is a folder for Aqemu in /system/apps.
I realy don’t know. I wonder why I have to reboot the machine after installing a software. In my other Haiku as a Virtualbox guest I never have to reboot. Hmm.

I could finally install Haiku on the internal hd of my laptop. I did the installation with the same Haiku system from my posts here before.
In my hd installation everything works fine. No reboots anymore and the installed software works.
Could perhaps be an usb problem. This problem is solved for me.

1 Like