Software Install/Updating

Hey I’m new to Haiku, installed it this morning using a Nightly Build.
The idea of pervasive multithreading is what attracted me.

What I like:
• Definitely speedy
• Small foot print
• Most of it just works
• I also think the interface is pretty cool

Though I do wish there was an easier way to install software, OS updates, and drivers. My wifi adapter on my Macbook Pro simply isn’t showing up.

Does there exist or is it in the works, an official application or terminal application to install packages and their dependencies?

installoptionalpackage is a dirty, dirty hack made by someone who had very little C++ progamming skills. (That’s me!)

Seriously though, that command is a complete hack that relies upon parsing the jam syntax of the build system files into a bash syntax. To this day, I’m amazed that it works as well as it does. :slight_smile:

It’s in the works. You can read all about the work here:

Welcome to the Haiku shell.

~> installoptionalpackage -l

Optional Packages that have been installed:
BeBook BeHappy BePDF BeZillaBrowser BurnItNow Bzip CARootCertificates CDRecord Ctags Curl Development DevelopmentBase DevelopmentMin Expat GetText Git ICU KeymapSwitcher LibIconv libmad libmikmod Libmng libmodplug LibXML2 MandatoryPackages Nano NetSurf OpenSSH OpenSSL P7zip PCRE Pe Perl physfs Python SDLLibs Sed SQLite Tar TimGMSoundFont TrackerNewTemplates Vision WebKit WebPositive WebPositiveBookmarks Welcome WonderBrush wpa_supplicant WQY-MicroHei XiphLibs XZ-Utils Yasm

Installable Optional Packages:
abi-compliance-checker apr apr-util armyknife bazaar beae beam beoscompatibility caya ccache clang clockwerk clucene cmake colors! cvs demopackage_audio demopackage_data demopackage_image demopackage_video developmentjava developmentpowerpc dmidecode doxygen droid fastdep friss gitdoc gperf groff hgrep lgrep libevent liblayout libxslt links lua man mercurial nanumfont neon ocaml opensound paladin puri rsync ruby subversion taglib transmission vim allegrolibs box2d fribidi lcms libart_lgpl libpaper

You might be able to get your wireless card working by installing the wifi firmware. Open the terminal and type “” then press enter.


Welcome to the Haiku shell.

~> listdev


I tried the installoptionalpackages but it does nothing. Is there something else I’m suppose to type after it?

I also tried the wifi adapter install and it fails with this:
Installing firmware for iprowifi2100 …

gunzip: stdin: unexpected end of file
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
… firmware for iprowifi2100 has been installed.
Installing firmware for iprowifi2200 …
… firmware for iprowifi2200 has been installed.
Installing firmware for broadcom43xx …

bzip2: Compressed file ends unexpectedly;
perhaps it is corrupted? Possible reason follows.
bzip2: No error
Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover’ program to attempt to recover
data from undamaged sections of corrupted files.

tar: Child returned status 2
tar: Error is not recoverable: exiting now
/bin/ line 271: cd: b43-fwcutter-012: No such file or directory
Compiling b43-fwcutter for installing Broadcom’s firmware …
… failed to compile b43-fwcutter.
…failed. broadcom43xx’s firmware will not be installed.
Installing firmware for marvell88w8335 …
tar: This does not look like a tar archive

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
mv: cannot stat /boot/common/cache/tmp/wifi-firmwares/share/examples/malo-firmware/malo8335-h': No such file or directory mv: cannot stat/boot/common/cache/tmp/wifi-firmwares/share/examples/malo-firmware/malo8335-m’: No such file or directory
… firmware for marvell88w8335 has been installed.

[quote=Sir Gan]I tried the installoptionalpackages but it does nothing. Is there something else I’m suppose to type after it?

if you type

installoptionalpackage -l

it will display two lists. The first list shows the packages that are already installed, and the second list shows the remaining packages available to install. To actually install a package, you type

installoptionalpackage [name of package]

Play with it a little. Try installing Colors! for example, or BeZillaBrowser. It’s case-sensitive, so make sure you enter the package exactly as it shows when you listed them.

Sweet! I just installed all of the optional packages. Typing this up in BeZilla.

However I still can’t get the wifi .sh file to work. This is kinda a deal breaker for me. :confused:

Got the wifi sh to work but my adapter still isn’t using up. I’m using a 2008 Macbook Pro.

Any suggestions?

device Network Controller [2|80|0]
vendor 14e4: Broadcom Corporation
device 4328: BCM4321 802.11a/b/g/n

Strangely posted same message twice, can’t delete.

Non-Supported Hardware

The following Broadcom 43xx devices:
bcm4311: vendor 14e4, device 4311
bcm4312: vendor 14e4, device 4315


Wait mine is 4321, is that compatible?

Wait mine is 4321, is that compatible?[/quote]

No. You need a completely separate driver for your chipset. None of the hardware in that family (the SSB-based Broadcom chips) is supported in Haiku.

I heard that the devs were working on a new installer, how ever I don’t mind this way of install packages as it makes it much easyer then geting them form haikuware, (if the site ever goes back online.). Plus the documenation is horrible and haiku does not come with an /boot/home/apps and that consoners me as some go into the /boot/apps and that worrys me. If any thing the devloper of this should put a link to a site or at least put comma’s so we know what packages are what as I keep geting erros that the package does not exist.