Software install fail

After some struggle I managed to create a full 32gb USB3 64bit bootable drive.
After running Software updater I try to install software with HaikuDepot, some work but most return error message like:

Fatal eror occured while installing package burnitnow: failed to commit transaction: The to be activated package “cdrtools-3.02-a09-1-x86_64.hpkg” does already exist. 0

or mostly:
Fatal eror occured while installing package yacreader: failed to commit transaction: The to be activated package “gmp-” does already exist. 0

Please, what to do?

I swiped the USB and made a fresh install from a PC booted with the DVD.
Seems to work now. Must have screwed up things first time.

You can try to open a terminal and use the command pkgman -install name_of_the_package. If it works then the problem comes from HaikuDepot.
If it still doesn’t work, use pkgman -full-sync before retrying.

Does your Haiku partition covers the entire 32 GB?

Yes, it was formated to Be File System. it has 20gb free space left according to DriveSetup

Sorry, I had no succes there

It seems packages were already there but not activated.
During your install, did you copy some packages manually to /boot/system/packages directory?
Dropping one two packages there it is ok and almost immediate but dropping dozens at once, your luck would be better rolling dice. Believe me, very bad idea.

I am new to Haiku so it is trial and error for me to find out how it works.
Made first a USB with Etcher and played around with it for a while trying to install programs in limited space with HaikuDepot. Problably it was already corrupt already when I made a full install to the new USB from this. What I remember ca 2500 packages was transfered then compared to 480 when I did a clean install from a DVD

Anyway now it works fine

Most of them weren’t packages but most likely icons from HaikuDepot cache folder if you started HaikuDepot at least once from the USB.

Can be so, but after installing almost all recommended programs now to play around with I still have 3gb more free space than first time.