SMTP Fails to Authenticate

I’ve been using an HREV47259 VM inside VMware on a Windows 7 (64-bit) laptop as my main e-mail machine (via BEAM) since late May of 2014. A couple days ago sending mail refused to work with the message “535 5.7.8 Error: authentication failed:”. POP still works fine with the same user/password combination.

This reminded me that I had installed a more recent HREV inside VirtualBox on a different computer in mid January, (I don’t have the access to the computer at the moment, and neglected to write down the HREV number), and it had this same problem right from the start. In this case it was a 32-bit version of Windows Vista acting as the host. (I filed it under “figure this out when I find time,” and it never made it back up to the top of my To Do list.)

In my trouble shooting, I did a fresh install of HREV48871 on two more machines inside VirtualBox: one a Win7-64 machine, the other a Manjaro Linux host. They both refuse to send mail in their Haiku VMs with the same error. SMTP works on both these machines both in the host OSes and in Linux-based virtual machines.

I’ve played around with all the settings that might have anything to do with networking, with no success. I’m stumped. I don’t think I made any changes in between the last successful e-mail send and when SMTP gave up to the host OS or VMware on the machine that used to work but stopped. I did change the account password in that time period, but the old password was the one that refused to work in the first place on the Vista machine, so that seems unlikely to be the culprit. Even if it was, say, the special characters in the password, I tested it out with a dictionary word + a single number password…no dice. Also, I’d tried sending on both port 25 and 587, so that’s not it. And it doesn’t seem like it’s a problem with the mail server or mail account in question, because I tried it out with more than one account and mail server. Plus, why would it work for POP, but not SMTP? Sigh.

I took one stab at trying to use Mail to send, but it died silently, as Mail is wont to do.

Can anyone help out? I’d really appreciate it. I would really like to keep using Haiku+BEAM for my e-mail needs. Thanks.

This turned out to be a Beam problem, rather than a Haiku problem. So with much help from Oliver Tappe, (and a fair amount of brow furrowing on my part as I figured out how to use Wireshark), the bottom was indeed gotten to. In Herr Tappe’s own words:

…the problems you have noticed turned out to be caused by two different bugs in Beam:

  1. In the prefs, when a password is stored on disk and you then tell Beam not
    to do that, it would grey out the password field in the GUI, but never
    actually remove the actual password from the settings file.

  2. If no password is available, the different authentication implementations
    used to ask the user for a password only to ignore that and use the one
    set in the prefs (which usually is empty, except for when bug 1 shows up).

These are fixed now, and Beam-1.2 (as opposed to 1.2alpha) has been released.

I didn’t have any luck getting HaikuDepot to use the most current directory of available programs so that I could update my version of Beam, but I was using such an old nightly that there was no good reason for me not to just spin up a more current HREV and transfer my files. The non-bugged version of Beam should be available in HREV49008 and up.


Nice to see you and Oliver buckled down and eventually found the solution!
You do know you can update Haiku to the newest nightly without a complete re-install? In case an update results in an impaired system, you can choose an older version from the boot options (hold SHIFT or SPACE when booting).