Slight problem with i855GME Extreme Graphics GPU (screen offset)


It’s my first day using Haiku natively on a physical machine, so I’m trying to use it for real now! The latest official Alpha that is.

Now, this is a first generation Centrino platform, meaning a Pentium M “Banias” 1GHz ULV core sitting on an Intel 855GME chipset plus second generation Intel ExtremeGraphics.

My problem is, that the entire viewport/screen is offset about 20 or 30 pixels down. So on the top I’m seeing a thin black letterbox, and on the bottom, part of the video output is off screen. It’s not unusable, but I’d like to fix this. And since subnotebook screens don’t have that “auto configure” function… well.

The screen is connected internally using a digital LVDS interface.

An excerpt of the listdev command:

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
vendor 8086: Intel Corporation
device 3582: 82852/855GM Integrated Graphics Device

Also, listimage | grep accelerant says:

864 /boot/system/add-ons/accelerants/intel_extreme.accelerant 0x22a5000 0x22b2000 0 0

Is there anything I can do to fix this? I really don’t want to switch off 2D acceleration. Installing a nightly build would be an option, but if there is an easier fix, i’d prefer to avoid that.


Awesome, this was my first forum post using a native Haiku OS machine! :slight_smile:

The first thing to do is to try one of the nightly builds, to see if the problem is already fixed. Get one at:

Alpha 4 is more than one year old, so there were a lot of changes and improvements. The nightlies come with some new bugs, but also a lot of bugfixes.

Ah, I feared that that was what I would need to do. Ok, I’ll first let my video transcoding tests with latest 2014 versions of libav+x264 run through, and then I’ll give the latest nightly build a shot.