Select boot volume (Current: None)

Hi all,

Trying to install Haiku on a T420. I only want Haiku on here, so used DriveSetup to wipe the disk, add a partition, init it and then install the bootloader (as Installation Guide | Haiku Project).

However, when I boot post install, I get the bootloader but it tells me that it can’t find any boot volumes. If I re-install Haiku, I can see the partition.

Seems related to After installing Haiku on an AMD A8 laptop "No Sys Loader!" error pops up as my partition ends up about 25% smaller than I ask for in the installer.

No sys loader is a different thing.

If your partition is created as the wrong size that sounds like a bug, could you file a ticket? (I suppose it could also be 1000 vs 1024 confusion depending on the displayed values thozgh)

Sometimes in the past you needed to make the partition “aktive”
Sometimess you need to run the makebootable by hand (install bootman from tools menu from the installer oder bootman from applications Anwendungen)

sometimes you need to make the partition bootable buy hand (this was verry rarely the case for me but this was years ago)

Ran into similar on my HP2000.
I finally got Haiku installed and bootable on my HP2000 today.

I had many issues installing bootmanager using EFI and a GPT partition table scheme and got nowhere with GRUB2 unless you count pulling hair and stomach ulcers as advancement. I eventually broke through doing the following.

I activated Legacy Boot Mode in my BIOS prior to executing the following instructions. The way my BIOS is (as most do) is that EFI stays on and retains precedence over legacy, but Legacy is permitted when EFI is not explicit. Now, the fun starts.

1.) I wiped my drive with GParted LiveCD, created an MSDOS partition table and formatted the whole disk with a single FAT32 partition.

2.) Fired up my Haiku USB thumb-drive and installed BootManager, rebooted the system making sure the BootManager was present and operated; should attempt to start an OS only to pop up on screen again in a loop.

3.) I resized the FAT32 partition shrinking it with GParted LiveCD then created a Haiku partition.

4.) Started the Haiku thumb-drive, formatted the Haiku partition (the basic routine Be File System).

5.) Changed Parameters for the Haiku partition marking it active
(DriveSetup > Partition > Change Parameters… then check the Active Partition box)

6.) Mounted the Haiku partition and installed Haiku to the Haiku partition.

7.) Unmounted the Haiku thumb-drive.

8.) Opened a terminal and executed the following command: cd /boot/system/bin

9.) Then executed the following command: ./makebootable ‘your haiku partition label’
(Remember that if there are spaces in the haiku partition reference it has to be in quotes)

10.) Using Find entered “bootmanager” and started the application from the results list: proceeded with the bootmanager installation update (backup). Your Haiku partition should be in the menu list options that appear after completing the bootmanager backup and checked by default; complete the bootmanager update process completely then reboot and enjoy.

Hope this helps.

1 Like

That configuration is not allowed. BootManager will erase the GPT partition table because they are stored at the same place on disk.

You never need to run makebootable manually. This is done automatically by Installer.

1 Like