Rust package broken


#1

When I try to install the “rust” package via pkgman in Haiku nightly x86_64, pkgman errors:

 nothing provides lib:libllvm_4.0 needed by rust-1.22~dev-1

I tried installing “llvm_libs” to see if that helped, but I get the same error message for the “rust” package either way.


#2

Rust wasn’t rebuilt after LLVM bump. As it kinds of needs itself to bootstrap the build, this isn’t straightforward.


#3

IIRC, the Rust team recently migrated to LLVM 6, which is why I opened a pull request at HaikuPorts switching to LLVM 6 release, and another one to fix the cross-compiled version in Rust’s libc, since building Rust 1.27 in Haiku still doesn’t work yet. I was able to successfully cross-compile Rust 1.27 with Haiku’s LLVM 5, but I’d rather aim for supporting LLVM 6 at this time.

But yes after bumping LLVM 6, we still need to check that Mesa builds and works with this change.


#4

You can try to use the (slightly older) packages that can be found at http://rust-on-haiku.com/downloads


#5

cool didn’t see this link before, thanks!