Running Haiku R1/beta1 on one-decade-old Mac laptops


Oh. It seems I am out of luck then…


I didn’t read through this whole discussion, but what are the chances of booting up a 32bit USB Haiku stick on Mac Mini (Mid 2011) ???


Not very high, you will have better luck with the UEFI enabled 64 bit version.


And even then it may be iffy. I can’t get Haiku to boot on my 2012 Mini or 2012 MacBook Pro.


What are the current main issues with 1-5 years old Mac, besides the UEFI stuff? Are there significative hardware incompatibilities that are difficult to overcome?

On my Mac, I am having trouble with the dual ssd setup. I somehow was not able to get the mac to boot from the main ssd only, and had to hack it by burning a fake install dvd into the whole secondary ssd (using dd). That worked with the 32 bit beta, but overtime I change anything in the secondary SSD, strange stuff starts to happen. For instance, installing a 64 bit nightly build causes the boot to only recognise that specific Haiku partition. Creating new partitions in the secondary SSD makes the haiku partition non-bootable and I loose access to all Haiku partitions. The only way to recue it is to do another dd of the 32bit install image.

I also had a situation where I would get a white screen forever. Not sure what I had just done at that time, however. I remember I had been trying to identify a Linux distribution that could be booted from USB on that machine, but I am not sure If I went on to try the dd trick with the Linux installer. I had to remove the SSDs and format the secondary one externally, and then do the dd thing again. I went through the whole process a couple times, trying to identify patterns, but didn’t arrive to much more conclusion than what I shared here.

I know it is very easy to mess up things when using dd and stuff like that, but I am sure that there is something wrong there. I mean, at least, repartitioning the haiku drive (my secondary SSD) should not imply loosing the boot section. And the main drive should be able to boot. I understand, however, that some of this may very well be Apple’s fault.


It seems like you have mixed gpt and intel partition maps, or maybe you did not install our loader correctly (the efi loader has to be installed manually currently). in any case this does not look like a hardware problem, more a problem of using uefi and apple doing everything they can to hide uefi from the user.


Yeah. I will try to stop myself from messing up with that stuff in this machine. :slight_smile:


Hi Victor,

indeed I think the realtek hda codec on our Macs needs additional initialization. I think I already found the code and will try to add that later. The thing is it is a lot of realtek specific code. I’d preferably add this code in a way that it does not mess up the original hda driver and keep its code clean. I already also found the code to prevent the volume from being so loud. I already added it and it works fine with my iMac. In addition, I added the hopefully (proper) quirks for you MacBook. I’d like to share a binary now with you to test it before I commit it to Haiku’s Gerrit for review. Can you send me your contact details (e-mail for example) in a PM so I can share the binary and instructions with you?

kind regards,



Cool. You can check your inbox.


Semi-related, I just got Haiku up and going on my 2007 (A1176) Mac Mini.
Had to burn a DVD as it wouldn’t boot successfully from USB, and have to use the safe video mode options but it runs and supports the network well. Haven’t had a chance to try audio (nothing to play and no speakers plugged in). If I could get the video driver working it’d be just about perfect (running VESA 1600x1200 on a 1920x1200 monitor right now…)


I’ll experiment on a late 2011 13" MacBook Pro on Wednesday. In the mean time, does anyone know how well the PowerPC builds work? I have an '03 PowerBook G4 that would make a kickass Haiku box.


They don’t work at all. Sorry :slight_smile:


Oh, alright. If anyone’s interested in picking them up, let me know, I’d be willing to test.
I’d do it myself, but I’m basically completely illiterate at C/C++.


Okay, I’ve been testing on the 2011 MBP. In order to get to desktop from the USB drive (couldn’t test from SSD), I needed to use rEFInd, Haiku’s safe mode, and the failsafe graphics driver. I instantly noticed that the touchpad did not support scrolling, and WiFi was not working. I could not test ethernet. I tried opening the User Guide, and it hit a kernel panic. Here’s my syslog:


The panic isn’t in the syslog. Please take a screenshot (or see if it’s in previous_syslog.)