Running Haiku R1/beta1 on one-decade-old Mac laptops


#21

Okay, thank you for letting me know. I’ll give it a shot tonight (EST) and see how I go!


#22

I am still fiddling with it. The Apple boot menu has its weird mysteries…


#23

64 bit works perfectly without rEFInd.

:smiley:


#24

In my case, I had it working but now it doesn’t. Still trying to figure out the reason. I did a clean install of MacOS, created more two partitions and used another mac and an external USB enclosure to install Haiku to the SSD. Now it doesn’t boot Haiku.

Probably it has something to do with the bug referenced here.
https://www.haiku-os.org/guides/uefi_booting

Unfortunately, after following the instructions from that page, I get the Haiku EFI boot manager and it recognizes the Haiku partitions, but the video Mode selection section says “None” and there is no option to go ahead with the boot process…


#25

Just install it using a burned cd rom nightly image, no issues at all. Even easier if your using the only drive that is in your Mac solely for Haiku.


#26

I think the difficult thing, besides the mentioned bug in the 64bit beta, is to configure a dual or triple boot without DVD drive and without wiping any data. I am now exploring with cloning the install images to the second hard drive to use it as if it was the install DVD. I will then try to install it into a partition in the main drive. Let’s see how it goes.


#27

@victordomingos I have been using Haiku for a couple of years now on an old iMac 24 inch early 2008. I’ve been using both the 32bit and the 64bit versions, and most hardware seems to work. What I normally do is create a FAT32 partition using Disk Utility of OS X, burn a CD with the latest Haiku and install it to the FAT32 partition. Of course, you need to (as you already discovered) use refind or refit. I have not been able to boot it using USB sticks, I believe this to be a know issue with macs. Maybe using a UEFI based image you will have more luck (haven’t tried that as I’m now just using software updater to update my Haiku).

About the hardware not working; there’s no iSight driver so that won’t work. However, I had limited succes with getting output from the HDA audio card; the thing is, at least for the iMac 2008, you’ll need to use a head phone. Still the audio is too low. I fixed this in the HDA driver a long time ago, so you would get louder audio but I never released a patch because I was running into some unexplained behaviour; not sure if it was due to the driver changes or the current state of Haiku at the time. In short, the macs (most macbooks and iMacs) need the HDA driver to deal with some mac specific quirks, I found them that time in the alsa drivers. I hoped that a recent Haiku commit containing a lot of these hardware specific quirks for the HDA driver would have fixed it for my iMac, but alas. I’ve been meaning to try and work on a fix again as I’ve lost my old changes, but haven’t got around it anymore. One thing I’ve been searching for is the specific quirks needed in the alsa drivers, but haven’t been able to find them anymore. The next thing after that would be getting audio via the speakers then…


#28

Am I missing something? I burned the image to an ISO, held down ALT when the Mac booted, selected “EFI Boot” and it’s just hung? Did you guys do something else?


#29

In my case, since it does not boot from USB and I down have a DVD drive, it’s very difficult to get things working. I had to take out the disk 3 times this week, which is not a trivial task at all in this old MacBook Pro.

The good news is that after doing a dd from a 64bit nightly build into the second internal hard drive, to simulate the presence of the install DVD, I could install it to the intended partition in the main drive and I have finally a bootable Haiku partition. Also, now I am able to select between the two installations (32 bit and 64 bit) as I intended, using Haiku’s boot options.

I just need to see if I am still able to boot macOS or ally and if I can reclaim the rest of the secondary disk into a new partition for data storage (after all this work, I am not going to risk removing that installation image partition, as I am not entirely sure if it’s being used for the boot process).

Thanks for the tips on the Mac hardware. Actually I have also found at some point in this adventure that, with earphones, in one or two applications it was possible to ear some very very low volume sound.


#30

That kind of hanging has also happened to me a few times, but I couldn’t find out the reason. I had to try again. If you are installing the 64bit version, I believe it’s better to use a recent nightly build, because there is an EFI bug in beta 1. If you are using 32bit, rEFInd is necessary.


#31

Thank you very much. I’ll give it a try.


#32

That’s what I remember too


#33

I found the driver again, at least for my mac it’s a Realtek based controller, a ALC 885 in this case. Indeed you will find the ALSA driver lists a lot of quirks for macs, see here (starting from line 2235):

http://git.alsa-project.org/?p=alsa-kernel.git;a=blob;f=sound/pci/hda/patch_realtek.c;h=3578f11c8e12f68f140f8528f351bc15d22ff51e;hb=e38d6d3a5e3df4a2a2c2254f19d787b759ea1fdd

it would be nice if they could be added to the Haiku HDA driver.

Edit: it seems the quirks for my card (line 1879 in the file above) are somehow present in Haiku’s HDA driver, some code in Haiku’s hda_codec.cpp (line 373 and further) seems to deal with it. It’s looks different to the Alsa driver only in two respects; the ALSA driver reads the card registers too and the Haiku driver sends the verbs in a different order. Since sound is not properly working on my iMac I guess either something goes wrong here or my cards needs additional setup. @korli any idea?


#34

I read somewhere that Haiku’s boot loader or boot manager had problems with boot partitions scattered through different physical disks and with partitions starting at more than 127MB. Not sure it it’s true or if it reflects the current state of things. I noticed however that my MacBook Pro it takes too much time booting. First, there is a white screen for more time than usual. Then a black one. Even pressing Shift to enter the boot configuration screen takes a long time. Then it not always detects the Haiku boot partitions in other drives… adding to that, this second ssd (placen in the ATA/DVD to SATA adapter) has a lower speed than the main one in the regular SATA connection (which is not a big problem since Haiku is in fact pretty responsive, with exception for the slow boot process).

So, I decided to do another experiment. I repartitioned the main SSD, shortening the macOS partition and creating a new one with the remaining space. Then I cloned macOS to the new partition, in order to allow Haiku to be installed in the first one. I rebooted to Haiku and used DriveSetup to split that first partition and installed Haiku 32 bit in the first one.

It still takes too much time booting. My current theory is that maybe the DVD position is making that SSD slower and can be messing the boot process.

I think I will try to change temporarily the boot sequence, using sudo vifs, disabling booting from the second SSD, and see if it works and if it improves the boot time.


#35

It didn’t work out. The vifs stuff seems to apply only to macOS known filesystems. There is something that just doesn’t seem right. Either some kind of bug in DriveSetup/installer/Boot Manager, or the way Mac copes with these partitions. I couldn’t make the existing partitions bootable, when I did some change (not sure what caused it) the Haiku partition from the second drive, I would loose access to the Haiku partitions on the main disk. I don’t know.

I had to do again the trick of writing the Anyboot image to the second disk in order to get back the boot section, that apparently I am not able to place into the main drive.

I think I better stay clear from DriveSetup and Boot Manager for a while. At least I have still my 32 bit partition with the apps I had installed. Let’s get back to work. I am currently contributing to expand the translation of some applications and the Haiku user interface to Portuguese.


#36

I don’t know where that 127MB thing comes from, I’m fairly sure we never had such a limitation in Haiku and probably not even in BeOS.

The “single hard disk” problem is in Haiku boot manager, but you can’t use that on UEFI based machines.

Anyways, in UEFI there is nothing about partitions when booting. You use only the UEFI system partition where you have to put the haiku loader. The loader then takes over and handles the next part of booting (including our early boot menu, etc).


#37

umm what about the 2000’s era machines? i means such PentiumIII, Pentium4, AMD k6-III, those macines runs perfectly linux with olders kernels such 2.6.8 or 2.6.18 releases… and gtk 2 based desktops…

what king of apps: mostly old emulators… some games… platform games… and some players for music and videos…also see pictures…

hayku can be used for those cases… CAN BE MADE AND USE HAIKU FOR THOSE?


#38

I think this should be possible to solve, e. g. by providing a default way to send feedback and data from your computer to upstream (but as an opt-in, so people specifically have to enable it; of course you can make it convenient to do so). Sorta like “crash reporting”, but more general. Perhaps with a bit of a wiki-functionality.
People could report their hardware and state what works and what does not work, a bit like the wine-hq database for games that work under wine.

I don’t have very old hardware anymore myself; mostly from 2008 or upwards (ok 2008 is not so young but not that old either…). I most definitely will put Haiku on one of these machines, but only when Haiku is sufficiently stable (which may or may not be the case, I don’t know; I will wait until the current beta-phase is over).

On a side note, UEFI was always annoying for me, even on Linux. It was so much easier with the hackish cfdisk + FAT table (or whatever was the name… before the GPT partition table).


#39

Hi Victor,

after a couple of hours experimenting I got the HDA driver to work with my iMac 24 inch again. It seems it’s head phones only now (need to test it more), but the sound is loud, clear and enjoyable. I will try to upload a patch to the Haiku repository soon. If you let me know what kind of hardware you have, I could try to add support for yours too. My iMac is Intel ICH8 based and has a realtek 889 codec. Maybe your MacBook Pro has the same or similar hardware, so it might be as easy as adding a device id to the list of quirks. The patch I’m using is actually meant for a MacBook Pro 3,1, that is a late 2007 model. That gives me hope that it actually will work out of the box. In the case you’d be willing to test my changes I’m willing to send you a binary too.

kind regards,

Tim


#40

That’s very good news. I will do a listdev in my Mac today. I think it is that audio card.

I sometimes can hear some very low volume sound from earphones, but nothing from the internal speakers. When I get that sound from earphones, if I turn the volume higher, it distorts a lot, even if the output volume is still very low.