(Resolved) How install Haiku R1/ beta4 64bit on raw metal erasing the whole disk

This is all you need for a legacy/mbr install.

1 Like

this looks easier,
not sure I can manage it, though

This is strange considering you having done it in the past.

In any case, wait for beta5 i suppose, maybe it will have made the installation slightly easier.

Would this help:

Put the USB stick image on the harddisk. That’s all.

Maybe with a Linux tool?

Try the installation with EFI step by step. I did this several times now and you cannot do many mistakes. If you want to use the whole harddisk, nothing can happen because all data will be “deleted” in any case. So, if you have a backup of your disk or don’t need the data - who cares.

I spelled it out step-by-step on this thread. It was for an early prerelease of beta4 but should still work.

1 Like

Partitioning just means “preparing a place in the drive”, doesn’t matter if it’s the whole drive or just a fraction of it.

(longer version:)
I guess that maybe @ninos could be interpreting “partitioning” as “dividing into various parts”?
It happened to me, when I started dealing with this things years ago.
Then I learnt to just do it, even if it didn’t make sense to me (Why do it for only one partition? I just wanted to use the whole disk!), and simply accepted it as a kind of “technical bureaucratic paperwork”, so to speak.
Only time later understood that partitioning means “setting the boundaries of the place (part) where the data will be stored” and formatting means “setting the way (form) the data will be stored inside this boundaries”. Simplifying a lot, I know, there’s still a lot of technical nuances that fly over my head.
Kind of like “laying out in the ground where the building will go” and then “doing the building itself”.
A building with thousands and thousands of tiny rooms :laughing:


Yes, 20 years ago when this project started, everyone using a computer was accustomed to these things. Because they probably had to use DOS or some other system like that.
Now, we can’t expect as much from users (which is good, it means they do more intesting things with computers than messing with these technical low-level things!). And so we need to rework this part a little.


Plus the fact that there is MBR & UEFI nowadays - I’ve been using computers since learning in the mid 70’s using DOS - & I still don’t actually understand UEFI, just that it’s different, & if you do things a certain way, your computer will boot up, just like when using the MBR.

So any easing of the installation process would go a long way to having other people trying/using Haiku.

Initializing the disc is one such confusion, & then partitioning it, also confuses new comers - not just here, but also Linux/BSD - if this could become ‘point & shoot’ so much the better, with a ‘custom install’ option for those who want something other than using the whole disc.

Unfortunately, a lot of people want to try alternate operating systems alongside of MS Windows, & that is where real problems generally start showing up…


I’m going to repeat myself here, but this is all well understood and all there is to do is upvote this ticket on the bugtracker which already plans exactly that: #16217 (Installer: Add Install Modes) – Haiku and hope it attracts the attention of a developer to actually do it. There is no need to repeat over and over that we need to do it, neither here in the forum or there on the bugtracker.


Apologies for the ‘noise’ - I hadn’t seen that it was in the pipeline to be done sometime.

As a newbie to Haiku, I’m still trying to get to grips with it & how it works. :wink:


I’m very new to Haiku. I downloaded the .iso and using dd wrote it to a blank HD. Would not boot. Then using dd again I wrote it to a USB which boots. I ran the installation procedure on the USB to install on the blank HD. Once again the HD did not boot. Finally using dd I wrote the working USB to the HD. Once again it did not boot. Could someone please show me the correct partitioning for the HD that will allow the USB installation utility to do its job? I will use Gparted under Linux to create the partitions.

Also is there a command line utility similar to Linux fdisk that I can use?

Thanks in advance.

See this thread as I posted just a few posts back.

I followed your posted instructions to the end of item 11. This is the partitioning on the drive.

Disk /dev/sdb: 596.17 GiB, 640135028736 bytes, 1250263728 sectors
Disk model: WDC WD6400AAKS-6
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xe906a8ce

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 976564223 976562176 465.7G eb BeOS fs
/dev/sdb2 976564224 996095999 19531776 9.3G c W95 FAT32 (LBA)

This is the content of /dev/sdb1.

root@office ion]# mount -t befs /dev/sdb1 /mnt/hd
[root@office ion]# ls /mnt/hd
home system trash

This is the content of /dev/sdb2, a fat32 partition.

[root@office ion]# ls /mnt/in

The drive still does not boot. I’m sure I’m overlooking something simple.

Ah yes, I did set partition 2 as bootable after my last post. Still nothing.

I have a similar problem to install Haiku on big partitions, i don’t know if have any ticket or something like that but i tried to install Haiku on big partitions but after that i cant even boot onto it. But if i partition on 64GB the system works.

It seems you want to use UEFI to boot.

Is your bios configured to UEFI boot, and to boot from the device you chose ?

Also, more like a matter of opinion, but I prefer to let the efi partition at the beginning of the disk, to avoid discovering which motherboards have buggy bios implementations …

Bios is set UEFI only. As for the boot partition I followed SamuraiCrow’s post which specifically said…

Create the main partition as BeFS leaving a little space at the end of the drive for the UEFI information. (You’ll need to format the partitions later.)

Do you think that shrinking the partition with Gparted will work, or do I have to start all over again? It’s a bit of a pain switching back and forth from an O.S. that works and I am familiar with to one I know nothing about.

Is there a space in the name of your boot partition? That causes problems.