RadeonHD Native Resolutions

So I’ve seen a lot of chatter regarding the work done (I wish I could remember the developer’s name so I could give him credit here) with the RadeonHD chip-sets.

I have a RadeonHD 5xxx Series card. From what I can tell, you need to run one of the nightly builds to use this driver. Unfortunately, I’ve had no luck getting the nightly to boot. On this past Saturday night, I tried the Hybrid and the GCC4-only builds.

The only release, from what I’ve tried, that works for me is the Alpha 3 release.

Does anyone have either a solution on booting a nightly successfully, an idea of which nightly might be more stable, or an idea on how to use the Graphics driver with the Alpha 3 release? I imagine, due to dependencies, the latter option is out of the picture.

I did look in my ‘Screen’ preferences and saw the VESA is, in fact, the driver being used on my system. Unfortunately the only resolution I could use looked a bit wacky on my display as it’s being stretched.

My display is a 27" LED with a native 1920x1080 resolution for reference purposes.


Hi kurtis!

Our local ATI/AMD Radeon driver (and more) specialist is Alexander von Gluck III, aka kallisti5. [Edit: I think I forgot is great-grandfather Wilbour… he’s actually the IV. :slight_smile: ]

Nightlies are quite stable. I guess you already tried using safe-boot options (i.e. holding SHIFT while booting to enter to the boot options menu?

Maybe it’s a regression since Alpha3, you could do a binary search to find the nightly that broke things for you.

Have a look at Reporting Bugs and gather all the needed info for a ticket at the bugtracker.

Hardware/driver issues are notoriously difficult to remote debug…


That’s expected. The screen will always look stretched on a widescreen monitor when using the VESA driver. The VESA standard is very old and limited, but allows at least something to be displayed.

This is the only part of your post where you talk about the bug you’re experiencing. Unfortunately, you didn’t provide a lot of information to help the developers fix the problem. :wink:

BUT, before you go posting more information here, please consider opening a ticket on the bug tracker detailing what’s going wrong when the latest Haiku nightly tries to boot. Please ask if you need help getting more information about what’s going on.


I love creating bug reports. The Haiku developers are very helpful. :slight_smile:

Thanks guys! I was actually under the impression that nightly builds are expected to be broken.

I did manage to run the latest in VirtualBox without any problems. That’s not my end-goal but it does show me, like you guys confirmed, that the nightly builds are supposed to be somewhat stable.

I’ll be sure to collect some more information when I get a chance and create a bug report respectively.

I appreciate the good information!

And while you do, Safe Mode has an option for video resolution – I boot to a 1440 X 900 display, for example. Might make things a little nicer.

Sorry for resurrecting this thread but I just managed to install Haiku A4.1 onto real hardware.

I have an AMD 5450 HD PCI-E card because of the HDMI, I managed to install Haiku but as soon as tries to load the Desktop I get a blank display, I managed to boot into the Desktop by using the safe video mode but my display is 16:9 HDMI and everything looks stretched.

I have searched around and I have read some contradicting posts, for some people works but not for others including myself. Is there any fix for this beside writing a driver for it.

Take a look at existing bug reports regarding radeon_hd driver:

If your problem is not there please create a new ticket.

Until this one is fixed you can remove radeon_hd and radeon_hd.accelerant files from /boot/system/… folder.