[R1/Alpha 2] Black screen after rocket icon


Just to report that when booting off a USB key that works fine with Linux, I get a blank screen after the rocket icon is lit up.

I tried booting while keeping the SHIFT key, with no result. Tried again while keeping the SPACE key down, same result.

This is an entry-level MSI/Micro-Star MS-7418 Wind PC desktop with an embedded Intel® 945GC NorthBridge chipset:

Is there a work-around, or is this hardware just not compatible with the latest alpha?

Thank you.

Good news. If you get to the last icon, it means you are very close to booting and very good chance Haiku will boot for you.

During boot icons, VESA driver is used. After rocket icon, native Haiku graphics driver takes over if found (ie: intel_extreme in your case). There was an issue with this driver and some 945G video chipsets (those found on Atom systems). Same problem you describe.

You should be able to boot into safe-mode unless you have a keyboard issue (which is not likely). You actually have to keep pressing SPACEBAR while booting and not hold it down. LEFT SHIFTKEY you actually hold down. Try SPACEBAR method because I have had best luck using that myself but both ways work.

Once in safe-mode, select to use fail-safe graphics driver + a specific video mode you want. After booting, you can search for and delete intel_extreme driver. That will make VESA driver the default for booting and running Haiku.

Recent nightlies have a fix for intel_extreme issue but introduce another graphics bug which may affect you.

Thanks for the tip, but unfortunately, still no go, whether by keeping the LEFT SHIFTKEY down, or by pressing the SPACEBAR on/off.

Since I was going through a KVM, I tried plugging the USB keyboard directly to the desktop, to on avail.

Is it possible to be warned when this bug will be fixed, so that I can take another look at Haiku?

Thank you.

Try a recent nightly build.

That bug was fixed for my Atom system (945G) with:
The bug was:

But there was a change which caused another bug. Frozen white screen during boot. Try nightly and see if this affects you too.

Adding yourself as CC to proper bug will inform you of any changes and updates made to it. Trying to find the right ticket might require a little work. Fixing bug can sometimes take a very long time - years to get done.

Thanks for the links. I successfully booted up an Acer laptop (3810T), and Haiku looks really nice :slight_smile:

As to how such a small team was able to come up with a GUI on par with Windows and much better IMHO than what’s available for Linux even today…