Qupzilla Not Downloading Properly


#1

Found Qupzilla in HaikuDepot but it ‘fatal errored’ while downloading …failed 'flite_x86()

…any suggestions?


#2

QupZilla depends on Qt5 which in turnes depends on Flite (A light-weight text-to-speech engine).
Maybe pkgman would show more info? Try top open Terminal and issue:

pkgman install qupzilla_x86


#3

Hi and thanks but I get the same result…no flite_x86()


#4

Wrong repo i suppose…


#5

I suppose It could be something with the repositories but with HaikuDepot your choices and flexibility are limited. The GUI allows All Repos or a choice of Haiku and HaikuPorts.

I use WebPositive but find it a bit flaky at times and related audio, as with Youtube, stuttery and not free flowing. I was looking for a more ‘efficient’ browser.


#6

https://depot.haiku-os.org/#!/pkg/qupzilla_x86?bcguid=bc434-LHJQ

https://depot.haiku-os.org/#!/pkg/qupzilla?bcguid=bc404-WSKT

https://depot.haiku-os.org/#!/pkg/otter_browser_x86?bcguid=bc194-MELO

https://depot.haiku-os.org/#!/pkg/otter_browser?bcguid=bc278-EXLV


#7

I think miqlas meant that the URL of your repo may point to an outdated repo.
Check with the Repository preferences (or “Manage repositories…” in HaikuDepot’s “Tools”) or “pkman list-repos” in Terminal. For 32bit Haiku it should be:

/> pkgman list-repos
        Haiku
                base-url:  https://packages.haiku-os.org/haiku/master/x86_gcc2/current
                priority:  1
        HaikuPorts
                base-url:  https://eu.hpkg.haiku-os.org/haikuports/master/repository/x86_gcc2/current
                priority:  1

#8

Thanks for the headsup…will check all this out!


#9

I ran ‘pkgman list-repos’ and the result was exactly the same as yours.

I have Haiku on a usb and tried it in an eeePC but got the same result…


#10

Have you updated recently with “SoftwareUpdater”? I had a quite new and pristine image on a partition. Booted into it, updated and installed QupZilla without problems.


#11

Be careful, there is an “EU” at the begining of the URL.
I havnt noticed that… Maybe you also not.


#12

@humdinger…Unfortunately, software updater also fails with ‘failed to download package Haiku,x86’. My instal, was done at the end of December so I felt it was a recent version.

@kim1953…the eu is there, thanks!

I have a feeling It may be best to start again…a new install may sort out my problems…any suggestions as to the best partition set-up?


#13

…and that is exactly what happened…thanks for persisting with me…new install does everything the way humdinger described.

Software updated and Qupzilla installed!