Problems with appserver and nv GeForce FX 5700

AppServer don’t want to work with NVidia GeForce FX 5700

Revision 13345 (and all latest)
Works only in safe mode (fake appserver launchs) when NVidia GeForce FX 5700 installed. But when i changed it to NVidia Geforce 2 MX 400 - worked fine.

Snapshot from 18 06 2005 worked fine with NVidia GeForce FX 5700.

May it be that sometime i can boot Haiku on my GeForce FX5700 again? :slight_smile:


Although I am not really familiar with the app_server, I have a few suggestions:

-try another colorspace and/or resolution: it might be that it works then. Are you sure you tested both cards with the exact same settings?

I can imagine the app_server currently trips over sworkspaces that use slopspace: different cards have different constraints here. Notorious is 800x600 in 8 bit color: if that mode works ok then the card tested :
-either doesn’t need slopspace for regular used modes;
-or the app_server respects slopspace (extra unused black space on the ‘right side’ of the screen to make a mode adhere to hardware constraints)

For instance Matrox Millenium cards need slopspace in the mentioned mode…

Of course, there might something totally different going wrong for youu. Just thought I should mention this particular hardware limitation.

Best regards,


Are you sure you tested both cards with the exact same settings?

yes - i made makehdimage /Haiku ("/Haiku" - clean mounted bfs partition), and i never made any changes to source.

Yesterday made checkout from SVN, rebuild - it launched ! : )))))))))))

But only black&white (when i watched screen settings - it was 8 bit colour and 800x600).

Then i tried to change colour\resolution in source (cpp in haiku/src/servers/app) and rebuild hdimage - resolution changed (1024), but colour is 8 bit.