Problems to create a new HaikuPorts recipe

Hi there!

First of all, I have to say that this is my first post in this fórum :smiley: Regarding my question, I have created a new program for Haiku, a native Chip-8 emulator ( Hence, I want to include it in the official package list as a recipe for Haikuporter. I have cloned both Haikuporter and HaikuPorts to do some testing but I am not even able to build existing recipes :frowning: This is the error I get:

In fact, I saw the same type of error with the recipe I created for my program, Pin8, and I decided to try with any existing one such as “BeVexed”. I just wanted to publicly share the program in a convenient way for users, i.e., in the package list, but I am not able to do it :frowning:

Thank you in advance for your help. I apologize if this question sounds “stupid” but even though I have used BeOS, Zeta and Haiku for years, I have no experience with HaikuPorter…

Kind regards.

PS: I do not even know if you are interested in including it. If you are not, feel free to let me know that. I just wanted to develop an App that I had not seen before in Haiku with C++ and get into the BeOS/Haiku API… Thus, this is my first Haiku program in C++ and it might not be as good / well-written as you want.

Make sure the haiku_devel package is installed:

pkgman install haiku_devel

If that’s ok, check carefully that you have created an haikuports.conf for haikuporter and configured it with the right architectures.

Hi @PulkoMandy,

Thank you for your answer! The package haiku_devel is installed and the haikuports.conf exists. However, I had forgotten to define my architecture in that configuration file and, after doing so, I have been able to run the recipe for BeVexed. Thus, I have advanced some steps thank to your help. Unfortunately, my recipe is still not working (in a different way, though):

That message is shown in a kind of loop until I just cancel the procedure. Besides, it is important to mention that I had to remove this “build requirement” before getting to that point: “cmd: mimeset”. Haikuporter said that build requires “mimeset” could not be resolved but that tool is already in my system.

By the way, “haiku_devel” is the set of sources and libraries conforming the Haiku API (for -lbe, -ltracker…), isn’t it?

Thank you very much for your time and help. Kind regards.

Uppercase letters are not allowed in recipe names. Try renaming it to pin8 instead.

For cmd:mimeset, we probably forgot to declare it in the haiku package.

And yes, haiku_devel is all the headers for the Haiku API. The libraries are in the main haiku package, but there are symlinks in haiku_devel to allow linking to them.

Hi again @PulkoMandy,

Renaming it to lowercase worked (it was my fault as it is commented in the guidelines for recipes :frowning: ). However, the procedure is still failing:

Kind regards.

You have to define the SOURCE_DIR variable in your recipe.
Check, what’s the name of the top-level folder in your tar.gz, and add it like:


So haikuporter knows, where it should search for the sources.
You should add it after “CHECKSUM_SHA256”.

Hi @extrowerk

It worked! Thank you very much, @PulkoMandy and @extrowerk for your help. As the HPKG file can be build and installed, it should be posible for me to do these final steps:

Kind regards.

Hi again,

I have already created the pull request, but Travis CI failed… :frowning: This is the error shown in the Travis CI log:

I am really sorry for causing so many problems :frowning:

Kind regards.

I commented on your PR.
You’ve closed it unfortunately already… :slight_smile:
Besides what I commented there, there are whitespaces at the line end in the “make” line and “addAppDeskbarSymlink” line. ETA: and a tab before BUILD()

Also, in the SUMMARY, its only “Haiku”, not “Haiku OS”. I’d even not mention “Haiku” at all. All software in HaikuDepot is for Haiku :slight_smile:

Oh, and welcome! :wave:

Hi @humdinger,

I thibk I have done what you required and the Travis CI gave me Green light! :slight_smile:

Kind regards.