Problem: Haiku CD booting on old PC

Hi all,

I just decided to try out Haiku for fun. I have an old computer for things like this, it’s from the mid 90s.
I just use it for fun, experimenting with some things. :smiley:
So I wanted to use it to try out Haiku, but it doesn’t boot the CD.
I mean, it starts from the CD, I see some “dots” running, then the screen turns black with a blinking cursor at the bottom.
Nothing works then.

This is the hardware which I use in this computer:
Brand: Commodore
Motherboard: Abit AB-PR5
CPU: Intel Pentium MMX 233MHz
Videocard: ATi 3D Rage II+DVD (2MB) (PCI)

I still use the original CD-ROM drive of the computer, and I think it could cause this problem…
I tried to boot another OS from CD (AROS, you might have heard of it), and I also get a problem there. They have GRUB on CD for booting, but I do not get the proper boot menu, and the background is black, while booting the same CD on my notebook gives a nice menu (with a bigger choice of boot options) and the menu is also colored.
Maybe both problems have the same reason… and I have the feeling it could be the CD-ROM drive.

However, I do not have another CD-ROM drive for testing right now…

Booting and installing Windows 98SE and NT4 works without any problems. I also tried to boot Damn Small Linux from CD and it worked.

I don’t think that it is a problem with the CPU or motherboard, because someone else with other hardware also had the same problem booting Haiku. (you can read that here: )

Does anyone have an idea how I could boot Haiku, or what might be the problem???
Thanks for answers…


Edit: I tried both, Haiku R1 Alpha 2 and the nightly build from August 29th. I tried booting the nightly build as live CD on a Notebook which I bought new about 2 years ago, and it worked!

Edit 2: On the hardware database at the ATi 3D RAGE II and II+ are reported to work, so I guess my 3D Rage II+DVD should also work. I think there has to be another reason for this problem… I also tried a newer CD-ROM drive now, but the same problem.

It means there is a bug causing Haiku to crash for you. I believe this bug is hard to track down and fix.

This bug looks like yours:

See how the syslog has your error and similar back trace to yours:

Take a picture instead of typing the output. :slight_smile:

Could be issue with ATA stack but hard to tell. Try disabling DMA, PlugNPlay and other stuff in BIOS and see if that does anything for you.

Can you enable SMART in the BIOS?

The problem of taking a picture is that I don’t have a camera at my hands right now. I just have the camera of my mobile phone which is relatively old, with an resolution 640x480.
I didn’t see any option in BIOS for enabling SMART, I’m not sure but I think there was also no option for DMA. There were not too many options at all.
However, I have also another computer here and I will try to install Haiku on that HDD on this computer. I don’t want to run the computer with the error message above, I want to run the machine which doesn’t give me any message. :smiley:
So if the other computer also don’t work, I will take the other one again and try to solve the problem with this error message…
Thanks for your help so far. :slight_smile:

try safe mode options. Select them all the first time around to save time.

While booting, hold down SHIFT key or keep pressing SPACEBAR to get into safe mode. Make sure you try enable fail-safe (vesa) video mode + choose a resolution together. Haiku might have a native RageII driver. Can’t recall - too tired to check now. Fail-safe mode will bypass any video driver but there one or two video cards the VESA driver does not support.

The issue could be anything though I would guess 1) CD-ROM drive 2) video card

without KDL or syslog hard to guess what is going wrong. on-screen debug could help out a little too.

It doesn’t do anything if I keep pressing SHIFT key or SPACEBAR.
Again, I see those dots, then black screen with this blinking cursor…

you actually have to hold SHIFT key down or keep pressing SPACEBAR while booting.

If you cannot enter safe mode, then the bug/error happens too soon. In that case, to debug would require hooking up serial cable between two computers and using terminal program to capture the output from that system while booting.

If you are good with hardware, you can remove hard drive, install in other computer, install to drive, test, and then install drive back in old system. If it boots, then the issue was CD-ROM related. (or dd the raw/anyboot image to the drive/partition if you run another OS)

SHIFT and SPACEBAR don’t work.
I think I will try to install in other computer and then put the HDD back into the old computer.
I will report the results as soon as I tried it.
Thank you for your help. :slight_smile:

I now tried to install Haiku on the HDD of the old computer. To do so I connected the HDD to another computer and I wanted to put the HDD back into the old one after installation… but as you may think I got some new problem now…
It’s surprising me somehow, because I can boot that CD on my Laptop without problems.
This is what I get if I try to boot the nightly build (29th August), it’s in a console:

PANIC: did not find any boot partitions!
Welcome to Kernel Debugging Land…
Thread 11 “main2” running on CPU 0
kernel stack: 0x82085000 to 0x82089000
frame caller :function + offset
0 82088b1c (+ 32) 80104fce <kernel_x86> arch_debug_stack_trace() + 0x0012
1 82088b3c (+ 16) 800759e7 <kernel_x86> stack_trace_trampoline__FPv + 0x000b
2 82088b4c (+ 12) 8010a832 <kernel_x86> arch_debug_call_with_fault_handler() + 0x001b
3 82088b58 (+ 48) 800774b3 <kernel_x86> debug_call_with_fault_handler() + 0x005b
4 82088b88 (+ 64) 80075c0b <kernel_x86> kernel_debugger_loop_FPCcT0Pcl() + 0x021f
5 82088bc8 (+ 48) 80075f6c <kernel_x86> kernel_debugger_internal_FPCcT0Pcl() + 0x0048
6 82088bf8 (+ 48) 80077824 <kernel_x86> panic() + 0x0024
7 82088c28 (+ 848) 800ca0c7 <kernel_x86> vfs_mount_boot_file_system() + 0x005b
8 82088f78 (+ 96) 800506f8 <kernel_x86> main2__FPv() + 0x00a8
9 82088fd8 (+ 32) 80066733 <kernel_x86> _create_kernel_thread_kentry__Fv() + 0x001b
10 82088ff8 (+2113368072) 800666d0 <kernel_x86> thread_kthread_exit__Fv() + 0x0000

I don’t know what all this means, I am new to Haiku. Does anyone know???
You don’t want to see what I get if I try booting R1 Alpha 2, that message would be much longer and I don’t want to type so much. :smiley:
However I will try to install on that HDD on another computer…

I was able to install Haiku to the HDD on another computer. However, after putting the HDD back into the old PC I get a black screen. At the top I can read “Haiku Boot Manager”. Then there is nothing, just at the bottom is written: “Select an OS from the menu”, and next to it in red color: “Error loading sectors!”.
So I don’t know what I could try now…

Edit: I know I could hook up a serial cable now to see if there are any further debugging messages, the problem is just that I have never done it before, so I would have to figure out first how to connect with terminal to that computer through a serial cable.
Another problem is that I don’t even have a serial cable right now…

There’s a issue in haiku_loader (the step after bootman or the MBR code)
see tickets #5539
and related


The only things that may work are (changes in BIOS):
a) enable SMART
b) disable DMA
c) try setting UDMA mode 2 (33 MB/s)
d) check your primary, secondary masters & slaves to match your setup. Also look at your hardware to make sure jumpered correctly.
e) try LBA, CHS, …

for serial debug (Windows XP):

  1. hook computers up with serial cable (null modem?)
  2. install modem in XP settings (choose communications cable between computers for your modem)
  3. open hyperterminal (or other modem program)
  4. check for serial port (COMx where you connected cable to x)
  5. disable flow control
  6. turn on Haiku system and it will send debug output through the serial port to your Windows XP system hyperterminal.

starseed provided no syslog in his ticket so impossible to know exactly what his bug is caused by. Maybe same as yours or maybe not. syslog or serial debug info is required to really see what is going on - otherwise can only guess.

Even if you file a ticket, this issue may not get resolved for a very long time depending how hard or easy it is to solve.

Thanks for the help.
The BIOS doesn’t have these options for SMART,DMA and UDMA as far as I can see, it’s really old. :smiley:
I already tried different jumper settings (slave/master).

However, I do not have a serial cable and no one close to me has one and I don’t want to buy one because it’s the first time I would need one.
So if I get such a cable within the next week or two, I will try it out and post what the syslog shows.
If I won’t get such a cable I want to say it was a nice testing, but it seems like I will have to keep on using Haiku inside a VM. :smiley:
Again, thanks for help so far.

EDIT: I have found a serial cable now. The idea came at 3:00am in the night. I suddenly woke up and remembered that I have an old analog modem somewhere, and it had a serial cable in the box… I just forgot it. :smiley:
So now I will try to connect it properly and to get it working…

EDIT2: As far as I know, for using the serial debugging mode I have to keep pressing SHIFT or SPACEBAR as I have been told. The problem is that this doesn’t do anything, I still get the same black screen where I should get the boot options, but with the same error message instead of the options.
So I think I won’t be able to get anything through my serial cable.
So maybe I will try Haiku in 6 months again on that machine. Thanks for the help so far!

I have the same problem like you. I reported this bug 19 month ago: .
Testing several bios options was unsuccessful. And serial-debug did not work at this early stage of booting.
The last “tip” from the mailinglist was that I should buy new hardware.

Serial debug is enabled by default. In Alpha releases it may be disabled. You shouldn’t have to hold SHIFT or press SPACEBAR for it. Serial debug won’t work if the issue happens too early on during booting (ie: boot loader issue).

Xberti, without syslog or serial debug log, a developer cannot fix your bug. Impossible to know what is going wrong. Can only guess that likely cause maybe the boot loader. Could also be something else causing boot failure. ie: will never get fixed. Or the right developer would need to have your hardware, in their hands, to check it out (try different code to get it to boot).

Your bug may never get fixed or take very long time so getting different hardware is your best solution.

Can you try with ImageWriter to create bootable USB drive?

EDIT: If booting LiveCD gives same issue then you have serious problem and very difficult to find the cause and fix it.

Sonic was able to put HD in other computer, install Haiku and put back into older system. He ended up with this error afterwards (PANIC: did not find any boot partitions!):

He got around the blinking cursor issue by doing above.

That error points to ticket below:

Which maybe affecting you guys also. It relates to the ATA stack - disk driver. ie: could be disk driver not working with your hardware or boot loader not wanting to load Haiku for you. (two very likely things that could be causing booting problem for you).

I met this blinking caret many times. CD, USB Stick or HDD lead to the same issue. Since it append very early in the boot process, I can’t provide any syslog, it “will never get fixed” ?

Getting a different hardware was a failure (even if I choose a chipset identical to that of a machine that worked! )
So : do you mean I should better leave away ?

I think that, people interested in haiku can understand that the system is unstable, but if the system doesn’t even boot they will not return!

I know, without debug-informations it’s hard to find a error. I am not complaining at the developers.
Btw.: I tried all possible options to install Haiku. Also to install Haiku in a different System and use this HDD in my PC, but nothing is working.
But buying new hardware is no option at the moment, maybe next year.

“It will never get fixed.” I will explain. If developer cannot figure out what is causing this issue for you; they will not know what code to change to get it working for you. So, unless they go fix that section of code which is causing the non-boot issue for you for some reason; you will never get Haiku to boot for you. ie: maybe they decide to change the (boot loader) code or go fix another similar bug which fixes your issue too - very unlikely to happen. Since you cannot get any debug information, your 2nd best bet to get this fixed is to get the hardware into developers hands (Axel or Ingo). Developers meet in Germany twice a year for coding event - this October should be next one; see if you can attend for two or three days but first ask on mailing list if Axel/Ingo can look at your system (bring it there).

I have used a 440BX motherboard and it booted Haiku without any issues. Please try with CD on your 440BX system because that one should boot.

Without debug information (syslog or serial debug log), a developer has to try trial & error to fix the issue. That means they have to read through the code, line by line, and visualize everything that is going on with each part of the code. It would require the developer to understand the code very well and know what is going on. Even then, it does not mean they will find the problem because they may look in one area and it could be something else affecting it or may misunderstand what the code is actually doing. - Lots of time and work to do this!!!

I have run Haiku on 3 or 4 different computers without any boot issues. Maybe you are not choosing good motherboard chipsets? Many (the majority) are able to get Haiku booting on their computers. It only does not boot on a small number of systems and no one can tell exactly why (they all assume something wrong with boot loader code).

Intel chipset seems the most compatible for me with Haiku but should work good on AMD and Nforce too.

PS Please update your tickets with 1) motherboard chipset + 2) PATA & SATA controller information (get this from Windows) + 3) hard drive maker (& model) & SATA or PATA drive
One of these is likely causing the issue for you but could also be your CD-ROM drives or even your burned CDs. You should try CDs in another computer to see if they boot (work). (could be SB600 southbridge related?). The more people with this bug & who give information above (1,2,3) the better can see if there is any relationship between the issue and with what hardware.

If they willing to fix this problem, I can donate my FSC Scenic xl-1107 mainboard inklusive CPU (PII233) and maybe some RAM to Ingo or Alex.
Because on this mainboard (440BX) the same bug exists (

For fixing problem, best to talk to them direct with email. Axel on holidays for 3 weeks. I assume they would try a couple of things and after certain amount of time give up of it not fixed. Maybe 2 hours?

Having the hardware helps but still trial and error without debug information. You could also ask if they would return it to you if you paid for postage back.

Contact those guys and find out what they say. Ask your questions; if they can use your hardware to fix bug 3441? how much time will they spend? how will they go about looking into and fixing problem?, etc.

Just because you give them the hardware does not mean they will fix the bug but at least gets you closer from where you are today