Prevent Tracker windows from being reopened on startup

How would I go about doing that? Whenever I reboot, all open Tracker windows reappear. I don’t want this behaviour, preferring to start fresh on every boot.

Strange thing is, I can’t find any Tracker preferences to control this behaviour, and it is the only application affected. Please tell me how to fix.

Haiku R1/Alpha 4.1 user

Close down all Tracker windows before you log out. You can do that in two clicks from the Deskbar.

Hi oueshcousin,

as Michel pointed out, there is no setting for Tracker not to remember open windows. Instead of selecting the menu item from the Deskbar, you could also use the quicker keycombo SHIFT ALT W before shutting down (or after bootup).

Alternatively, you could add this to ~/config/settings/boot/UserBootscript:

waitfor Tracker
hey Tracker 'Tall'

This sends the same message to Tracker (after making sure Tracker is running) as the above mentioned keycombo on every bootup.


I found UserBootscript in a different locations: /boot/home/config/boot/

It worked, thanks!

open StyledEdit

enter thest two lines:

#!/bin/sh hey Tracker Tall

save the file as /boot/home/config/settings/boot/launch/
right click on and select "Get info
under Permissions, select all the Execute check boxes.

reboot to test. It worked for me.