Post your Haiku screenshot!

How is this possible?

x86 based Kindle? Secret work on ARM port? VNC server? Putting an Haiku screenshot in an e-book?
Lack of keyboard makes me think the first two options are out :smiley:

1 Like

Nothing fancy, just a VNC client on a jailbroken Kindle.
But it have touchscreen, so a virtual-keyboard would be possible if one ports Haiku to ARM, or even with VNC too.

5 Likes

I like this one! Very peaceful.

Wow! I have an idea to port a basic, open UI over to the iPad over a personal server, but that’s a dream of mine.

Here is a recent snapshot of Haiku hrev51987 with my successful Haiku build of Mesa 18.1.1 (OpenGL 4.5 API/Vulkan 1.1 driver work) and checking out some NetFlix movies in WebPositive.

4 Likes

Like some of the other screenshots here, it have a lot of picture noise as horizontal lines.
What bug is that?

And I am right, that all screenshots with the noise lines are taken in Haiku itself and all screenshots without them are running Haiku in an Virtual Machine and the Virtual Machine or the Host Operating System have taken the screenshot?

I never seen any noise on my screenshots, and i do them in Haiku without any vm.

Yes, I think there is a bug in the screenshot app, it uses 32bit PNG and leaves the alpha channel uninitialized, but declares it as present still (it supports transparency to do proper single window shortcuts, with the window tab, windows may not be exactly rectangle).

they almost never do if you consider the title tab

My HiQDock (MacOSX Dock emulator written in Qt/QML) running on recently nightly showing Vision and Qt Creator apps and my DigitalQClock at the top to the left of the Deskbar:

6 Likes

Can I use some of the screenshots on my blog?

Here’s a screenshot from my Haiku installation which I took today.screenshot_20180910

3 Likes

NetSurf 3.8 on Haiku hrev52358 showing Haiku Depot and Haiku Bug Tracking web pages.
netsurfnetsurf2

2 Likes

I downloaded NetSurf and the site says to extract it. The file I got doesn’t appear to be an archive and it doesn’t appear to be an executable. How’d you get it to work?

Or am I missing something blindingly obvious (always a possibility!)?

Oh, I downloaded it directly from the NetSurf website.

It should be an executable IIRC. Just chmod +x it.

Yep, tried that. Tracker says it can’t start it (invalid argument) and from Terminal it says it can’t execute the binary file because it’s not an executable.

But it’s also not a .ZIP or anything that Expander wants to work with.

I should just wait until 3.8 makes it to HaikuDepot.

Weird, I tested this with the NetSurf devs and it worked fine. Unless you are using an x86_64 system? The build they provide is 32bit only.

Ah. That would be it, then. I am running the 64-bit Haiku. Now it all makes sense.