Playing music

I can play ogg vorbis or mp3 files with the MediaPlayer. But the sound is quite choppy and cracks quite much. I noticed if I disable a CPU (it’s an amd64 dual core), it seems to sound a bit better. Yet if I do something on the system (right clicking on the ProcessController, clicking on a tab in Firefox/BeZilla), then the sound is even more degradated, as if my computer was not powerful enough to handle this. Is it normal in the current state of Haiku?

I’m having the same problem. Now in order to even get sound on my machine (an AMD64 w/Audigy2 Card). I have to remove the Audigy drivers (emuxki) and install oss. For some reason the stock drivers do not work. I hear the “pop” but no sound when playing music. It works but its awful choppy.

Try VLC & see if that works better for you:

Maybe MediaPlayer issue. Let us rule that out first. If VLC does the same then maybe buffer or sound card driver issue. Fairly sure OSS allows you to change the buffer setting but you’ll have to check for it yourself.

hmm, good idea. It’s the same on VLC. Now I have several BeZilla tabs open, it’s even worse today. And disabling one of the CPU is much better, yet it’s still sounding not normal.

When running vlc from the terminal, I got those kind of messages:

SoundPlayNode::SendNewBuffer, event scheduled much too late, lateness is 18240
_SoundPlayNode::SendNewBuffer, event scheduled much too late, lateness is 48602
_SoundPlayNode::SendNewBuffer, event scheduled much too late, lateness is 25499
_SoundPlayNode::SendNewBuffer, event scheduled much too late, lateness is 18161

Setting priority for vlc to urgent or real time doesn’t improve the sound much.

There probably still are some issues with either Haiku’s kernel scheduler, the Media Kit and/or sound drivers which makes sound playback so hit or miss :frowning:

We definitely want to improve this as one of the great aspects of BeOS was rock solid playback of media under all conditions.

It would help if you logged a bug with your specific hardware configuration (copy the output of listdev from the terminal.) This area isn’t my expertise so I’m not sure what else you should include in the bug, but it is definitely suspicious that turning off a CPU makes the sound better.

One little tip when logging the bug: if you create a new account on our Trac please check your email (and SPAM folder) for the confirmation email. You must confirm your email before you can log a ticket. Thanks!

  • Ryan Leavengood, Haiku developer


Thank you for the advice Ryan, I’ve opened this ticket there:

Hi farvardin, if this helps maybe a tiny bit, I get those messages about “event scheduled much too late” constantly, however my sound works ok. I don’t know what that means, but…

Another thing to try is to uncomment the line “serial_debug_output false” of the file “~/config/settings/kernel/drivers/kernel”.
The serial debugging is known to sometimes mess up timings.


I tried to uncomment the line “serial_debug_output false” but it was the same.

Someone gave a solution on the bugtracker thread:

I had to create a ~/config/settings/kernel/drivers/auich.settings file, and I’ve set :

sample_rate 48000
buffer_frames 4096
buffer_count 4
use_thread false

And now there is no more cracking and error messages. Problably the buffer_frames should be set to a higher value by default.