Playing mp3's choppy sound

device Multimedia controller (Multimedia audio controller) [4|1|0]
vendor 13f6: C-Media Electronics Inc
device 0111: CM8738

l have a C Media 8738 chipset based Soundcard which i believe is compatible with Haiku. However i was unable to get it to work. l then discovered i needed the optional OSS package which i have now installed and sound is now working. However when i use the media player to play mp3’s or video’s with the sound is very choppy and distorted and when i load another application it stops altogether.
l appreciate i have only ancient hardware a 600 mHz processor but i have 384mb ram.
l read on a previous post that others are having the same problems with much higher spec machines than me and a config file had to be made to solve the problem. Any help would be appreciated. As i dont want to go back to debian linux im enjoying Haiku too much, but i need my music!!

Read this post and the one after it.

Haiku stores system (text) config files in:
where “~”=/boot/home

You’ll want to disable serial debugging in kernel config file. Plus, you’ll want to fix up your oss config file ( instead of auich.settings ). One or more of oss_??? is what you may have to change.

Read this too to help you:

Ok thanks for your suggestion . Just an update for anyone maybe having the same problems.
lve tried changing the settings but was still having the same problems. l then decided to purchase a secondhand Soundblaster 5.1 sound card from ebay which i know uses the native haiku driver rather than using OSS.
However the sound problem playing mp3’s was still the same. l then downloaded and tried the optional VLC player package rather than use Haiku media player. This did did seem to correct the problem, but it still then became choppy and distorted and sometimes stopped when loading another external application such as Bezilla or any resource hungry activity.
l then decided to download the Beos CL-Amp package, and the problem now seems to have disappeared and i can play mp3’s and browse the internet without any degradation in sound quality.
l have therefore come to the conclusion that this maybe an issue with my hardware not being fast enough or rather the Haiku Media player being too resource hungry in its current state on my ancient hardware. Anyway i’ve solved the problem for now just have to use the old Beos CL-Amp, until i can upgrade.

I use the same soundcard…

with an P4 2400MHz with 1.5MB Ram

but same problems with sound…

@ Bruno
with an P4 2400MHz with 1.5MB Ram

you might want to upgrade from 1.5 MB RAM :slight_smile:

You may want to remove all other sound card drivers from Haiku and see if that does anything.

you’ll find them in:
& in

bin houses drivers for everything so you have to know which to remove. look at dev/audio to figure out which to delete.

I believe CL-Amp provides better buffering and why sound works better for you.

Your problem is either serial debugging ( which I believe you turned off ), driver conflict or un-configured setting file. Playing mp3s takes very little CPU & RAM so that won’t be an issue.

Stephan appears to have added unfinished CMedia support which may cause an issue for you. Remove cmedia ( and other ) audio drivers.

See here for Haiku change (added driver):

and Stippi comment here to remove cmedia audio driver when using OSS:

Huh? I don’t believe this is a memory issue at all… Haiku runs reasonably well in 256mb RAM and less.

I can get perfect sound output on slower machines (2ghz Celeron) with supported sound chipsets (auich) with only 512mb RAM, so I would guess most issues being seen on faster hardware with more RAM are either bugs in the driver, or interrupt sharing problems causing latency issues.

Edit: The 600mhz machine is probably just slow and suffering from latency.

Keep in mind that Haiku currently has quite a few debugging checks happening in the kernel when allocating/deallocating memory and such - that stuff is enabled by default on all builds of Haiku and you have to create a special kernel user config header to disable them (instructions in trunk/build somewhere)

Bruno said, 1.5 MB ( megabyte ) RAM instead of 1.5 GB RAM - big difference. I know it was just a typing mistake but thought I’d jokingly point it out.

LOL, I missed that too - sorry :wink: