Pkgman update "General system error"

When I tried updating Haiku today pkgman fails refreshing repositories with a “General system error” message.

~> pkgman update 
Refreshing repository "Haiku" failed  0%: General system error
Refreshing repository "HaikuPorts" failed  0%: General system error
Nothing to do.

I tried to run this command with --debug 10, but it does not provide more details on the refresh step.

Currently my system is at revision hrev53416 (x86_64). Network is up. Any idea what could be causing this and how this can be fixed?

Noticed something: WebPositive is complaining about not being able to verify SSL certificates. Maybe this is also the root cause for the update failure, maybe something broken with openssl?

Would there be a way to manually update to latest revision? Or maybe a mirror that is available without https? Currently I use the default repositories:

If your problems is expired root certificates, you should be able to manually download and update the ca_root_certificates package.

1 Like

Also check your clock settings. SSL errors can happen due to wrong time.

1 Like

Indeed it was the time, I should have thought about this :smiley: Thanks both of your for your help.

It would be nice if pkgman could be smart enough to report such problems instead of this general error.


There’s an open ticket somewhere about it, yes. But more significantly, we already have a “synchronize clock on network up” feature. So is that not working in this case?

1 Like

“Synchronize at boot” is active, I am not sure why this failed. What actually could have caused this is that I have Haiku running in a VM. And around of the time of last update end of August I actually did not power it down but only saved the VM state because I was in the middle of some work I did not want to loose.

1 Like

Hi all, I am trying to build the haiku code. I am following the instructions given here:
I have configured Haiku successfully and whenever I hit the command jam, I see the following error after some time:
ERROR: cannot verify's certificate, issued by ‘CN=R3,O=Let's Encrypt,C=US’:
Unable to locally verify the issuer's authority.
To connect to insecurely, use –no-check-certificate’.`

wget --retry-connrefused --timeout 30 -O "generated/download/gcc_syslibs_devel-8.3.0_2019_05_24-7-x86_64.hpkg" $source/packages/gcc_syslibs_devel-8.3.0_2019_05_24-7-x86_64.hpkg || exit 1
touch "generated/download/gcc_syslibs_devel-8.3.0_2019_05_24-7-x86_64.hpkg"

...failed DownloadLocatedFile1 generated/download/gcc_syslibs_devel-8.3.0_2019_05_24-7-x86_64.hpkg ... ...removing generated/download/gcc_syslibs_devel-8.3.0_2019_05_24-7-x86_64.hpkg

...failed updating 1 target(s)...
...skipped 7 target(s)...
...updated 6 target(s)...

I have tried to run the commands given here still it shows the same error.
Can anyone tell me what i may be doing wrong.
Thank you!