Package Manager Woes

Hi All!

I’m trying to create a package for my app. Somewhere along the line I made a mistake in my .PackageInfo file and now what I have are binaries deployed that I cannot remove. Creating a working package does not remove the binaries even though they have the same names (located in bin and apps). When I first made the error, I tried uninstalling the package via HaikuDepot, but that failed, presumably due to the same error.

So, how do I remove files that were installed manually? I really don’t want to wipe my whole system to get rid of them.

Thanks in advance!

The files doesn’t extracted at install, they just virtually attached to the live system. So if you remove the hpkg from the /boot/system/packages folder it will remove every problematic files automatically.

Interesting. I did that, but it did not remove the files. ;(

Oh shoot! Hold that…I rebooted and the files went away!

Thank you!!

you need to press strg permanently before you have permission to remove a file from the system/packaged folder