Otter Browser won't Update or Download

I tried updating Haiku R1 Beta 3 but when it tried to update the Otter Browser, Software Updater stopped with an error: Unable to download Otter Browser. I has to uninstall Otter for Software Updater to complete.
After that I tried to install Otter from Haiku Depot but got the same error. I then tried installing it with pkgman and got the same again. This is the output in terminal:
Welcome to the Haiku shell.

~> pkgman install otter_browser
100% repochecksum-1 [65 bytes]
Validating checksum for Haiku…done.
100% repochecksum-1 [64 bytes]
Validating checksum for HaikuPorts…done.
100% repochecksum-1 [71 bytes]
Validating checksum for LOTE…done.
The following changes will be made:
in system:
install package otter_browser-1.0.02-1 from repository HaikuPorts
Continue? [yes/no] (yes) :
Re-using download ‘/boot/system/packages/administrative/state_2021-08-19_12:44:28/otter_browser-1.0.02-1-x86_64.hpkg’ from previous transaction (partial)
*** Failed to download package otter_browser: Range Error

This looks like a bug in the packaging system, it is trying to re-use a package from the previously installed packages directory and incorrectly comes to the conclusion that it was not fully downloaded, and then tries to download the rest, to which the server responds that it doesn’t have that rest.

I am not sure if there is a ticket about this atm.

As a workaround you can use this:
pkgman -i /boot/system/packages/administrative/state_2021-08-19_12:44:28/otter_browser-1.0.02-1-x86_64.hpkg

1 Like

Thanks for your reply. That command in Terminal just gives the help for using commands. I copied and pasted it.

oh, sorry it’s just i, no minus, as a shorthand for install

That installed the Otter Browser.