Otter Browser is running much more smoothly

:c so sad news

1 Like

Hello. Did you tried disabling WebGL?
Check the about:config settings and look for EnableWebgl and set it to “no”.

I found that Otter is more prone to crash when that option is enabled. (I recently fill a bugreport at haikuports about that).

2 Likes

I can’t even get that far - it crashes immediately on opening… Is there a config file somewhere that I can tweak?

When you start Otter Browser, it tries to load some page in special?

You can try deleting the settings folder:
/boot/home/config/settings/Otter

That will regenerate the default settings. Try if after that, you at least can open Otter without crash.

2 Likes

You were on the money - the default file in the configs was nastily corrupt (can’t even delete it) - but I moved it into a quarantine and now the lovely Otter Browser works once again :slight_smile:

Care to explain what you meant here?

Maybe the cause is some filesystem corruption? Try to check the filesystem using (from Terminal), the command 'checkfs’

location at which it will do “no harm to others”, ie interfere with Otter loading, scare small children, etc.

Yep - it was dirty dirty filesystem corruption - BFS wasn’t entirely sure what it was looking at :wink:

Thanks!! I was looking for the beku-flavoured ‘fsck’… checkfs vaporised the file in question (a desirable outcome).

i’ve had this happen multiple times as well.

1 Like