Nvidia Chipset Support

I recently picked up a HP XW9400 dual quad core workstation which uses the Nvidia nForce Professional 3600 MCP. I have tested it with the 46589 x86_64 ISO. It boots to the live cd from a USB stick, and everything appears to function correctly, except that it does not detect any of the hard drives connected to the system. Should I file a ticket for this issue? I’d like to be able to install Haiku on a spare drive for testing on this hardware platform.

Sure, file a ticket. You can try to change IDE mode in bios to AHCI/Legacy/whatever.

Thats what worked for me when the hdd were not seen. Turning on ahci allowed the CD and HDD to be seen. TJ

Problem solved. Moved the drives from SAS/SATA to SATA, and disabled SAS in the BIOS. Haiku now recognizes the drives and installed.
However, after booting into the hard drive install, the speed is very slow. Mouse or keyboard commands take a few seconds before something happens, and it has frozen at least once already. I’ll start filing bug reports once I get the latest 46601 x86_64 nightly installed.

The slow performance and freezing was being caused by a new MS Comfort Mouse (USB) Model 1478. Once I switched back to an older MS Basic Optical Mouse (USB) everything worked as normal. The mouse support issue should probably have its own ticket. No problem with the Nvidia chipset. I’ll add this system to the Haikuware Hardware Database as compatible with 64 bit Haiku. Alpha 4.1 never got past the third icon on the boot screen.