No SSIDs with iprowifi4965 on ThinkPad T530

Hi all! I’m currently setting up a Lenovo ThinkPad T530 for use with Haiku to build and package some software, as bare-metal seems to work nicer than a VM.

Everything is working well, except wifi using the iprowifi4965 driver, which does not show any SSIDs (“no wireless networks found”)

The issue occurs with the original network card (an Intel 6205) as well as a lower-end Intel N-135 adapter (that seems to use the same driver). I also tried a Broadcom BCM43228 based card that was not supported (did not show at all), even with wifi firmware downloaded via Ethernet using the shell script.

This T530 has been modded with the 1vyrain BIOS mod to allow for removing the wifi card whitelist, but the BIOS is not Coreboot or any other full replacement - it is original, but with more options available. I don’t see this as being an issue, but it is worth mentioning. The version is G4ETB7WW (2.77) flashed a couple of years ago. The Intel 6205 card I’m (mostly) testing with is the original wifi card that came in the laptop.

Rebooting into Lubuntu 20.04 works as intended and SSIDs are available. I have tested primarily with the physical wireless switch on (green) but have also checked with it switched off. I have not tested the device on a FreeBSD-based OS.

Ethernet works fine, and I have fully updated the R1/beta3 installation as of time of writing. The issue is the same whether booting from live USB or installed to the internal SATA SSD (in UEFI mode). Disabling APIC causes an immediate kernel panic (at least when installed on the SSD) as the boot device is unavailable.

Running an ifconfig scan via the terminal stalls with no output. I have both a WPA2 network and a unprotected network available via a Ubiquiti AP AC Lite, as well as 3-5 other networks broadcasting from consumer routers that I do not control.

I’m more than happy to help with any troubleshooting, or replacing the card if that’s the most effective option. Thanks!

1 Like

Please open a ticket at instead


I wasn’t able to open a ticket (no activation email from Trac, tried 2 different email services) but was able to find a closed ticket with the same issue, and can confirm that the issue is fixed on nightly hrev55711.

1 Like

The particular relevant ticket here is #17458. A workaround was committed, but the underlying problem still has to be solved.

1 Like

Thanks waddlesplash. The ticket I saw was #16789 which is more specific to the particular wifi card, but I can confirm that it’s working in hrev55720 as well.

1 Like