No sound - Realtek ALC880 HDA on BeOS 5.0.3 (DevED 1.1) with OSS driver

Hi all.

For the fun of it yesterday I tried installing BeOS on my machine again. The main reason it was not already installed is because in the years gone by I never managed to get the sound working (except with the pc speaker driver). I saw there is an OSS port of the driver ofr BeOS/Haiku and I wanted to try it out.

After installing, when Media server is starting I can hear a silent cracking sound for about half a second, but after that only silence. I can choose Intel HD Audio as my input and output, and I see (too?) many volume sliders in the mixer, but whatever I do there is no sound. If I remember correctly the same happened when I used the non-OSS driver.

My machine is an Asus A6Va notebook (I tried plugging the headphones in, but also nothing), and the OSS works on FreeBSD installed on the same machine. I suppose it would work in linux too, but there I use ALSA.

Now, I’m no expert, I just heard a phrase “pin mapping” and if I understand it correctly it might have something to do with this. I also did something called “codec dump” in linux before for something unrelated. Can that be of help? I’m just throwing ideas so if I’m wrong somewhere please don’t bite :slight_smile:

I have been using BeOSR5.02 Bone and a nforce2 mainboard chipset, that has alc655 Realtek sound. It works well with this version of BeOS. I’m not certain how well the driver in this version would work with a alc855.
I will try a find out what driver and version it is using and come back here with the information.
It might be a bit late now. I only saw you’re question today.

The driver my version is using (BeOSR5.02 Bone) is: ac97_module. In Media settings App, it says; Yellowtab Generic ac97_module. This version of BeOS and the driver might be breaking copyright to be freely available. It had been available on Bebits for a short time but was stopped.
I myself have been quite desperate to find a version of BeOS that would work with my network chipset and sound and none except this one derived from Yellowtab has worked. Haiku itself does work a bit with my sound and works with my network card but ofcourse it is not fully ready for general users.
I have the driver or the whole OS version but would it be legal for me to share both or just the driver?