No Sound on my ICH3


I’ve finally decided to try Haiku on real hardware; and boy am I impressed! It’s kind of like when I first tried BeOS and it felt so quick and smooth. Great job guys.

The computer I’m using is an older Thinkpad A30 (PIII, Mobile Radeon…) and it works great overall. I haven’t tried using a WIFI card yet but I think I’ll wait a couple of months for that since it looks like great things are coming.

One thing that is not working for me though is the sound. It seems that the audio chip is detected because I see an AUICH device and I can select it for output. However if I get a sample .wav file on the internet and try to play it, nothing happens. I added the open sound driver and then I get an ICH3 device I can select for output but the same thing happens: no sound. Can anybody help me troubleshoot the issue?


You will have to file a ticket and include your syslog. Your syslog gives information on your hardware and drivers loaded while booting the OS.

Remove auich driver if you use OSS. Can cause conflict having both installed. OSS should at least work for you.
look for auich driver:

move it to Desktop and reboot.

Thanks for your help! The OSS driver works after moving auich.