No partitions

When run Beos MAX from the live CD and I clic on mount, it shows both my hard disks but without any partitions. Then if I clic in any of them it shows an “OS error”. So I can’t install BeOS neither Haiku.
I suppouse this is because BeOS founds strange my partition table, but I need more than 4 partitions. (got 6)
Any idea to solve it without formatting? <- I’ve already repartitioned once and I can’t be doing it once a month.
Is this a problem of BeOS or will I find it if I get to install Haiku?
Thanks in advance.

Are your hard drives SATA or PATA? ( SATA is not supported ).

6 partitions per drive or 3 partitions on each drive? Example: 3 partitions drive1, 3 partitions drive2?

What filesystems do they have? ( I know these work, can be mounted, for sure, fat32, bfs, ext2/ext3 ). Other filesystems may not work.

Try DriveSetup to see if it can view the partitions on the drives. Be careful. You can also “Intialize” the partition you want to put BeOS or Haiku onto ( it wipes partition clean and creates bfs file system on it ).

Both drives are connected by separated IDE busses, both as master of each.

The six partitions are in the same hard disk: three primaries and three extended. One is ntfs, two are ext3 , a swap, one without format and another is BeOS fs. One of the two ext3 and the BeOS one are both primary partitions.

The other disk is fully formated as ext3.

I’ve already seen DriveSetup but the last time lost all the extended partitions and some of the primary ones… It seems to probably let me reestablish all the partition table but like if it were empty…

I checked and DriveSetup can only work with 4 partitions.

I believe it is only capable of handling upto 4 primary partitions and does not know how to work with extended partitions ( same thing may apply to BeOS mounting. ie: Have you ever been able to mount an extended partition? Or could be because you exceed 4 partitions? One of these is probably the cause ).

Starting up DriveSetup to see the partition layout would probably not destory the partition table, but I can’t say for sure. Do so at your own risk.

Your best bet may be the 2nd disk with ext3. Repartitioning it with 2 primary partitions would be the way to go ( ext3 & bfs ). Partition Magic may help do this the easiest.

Or repartition your 1st drive so that you use only primary partitions ( up to 4 - which is the limit anyways ).

I just downloaded a haiku raw image and run it in Qemu. Pretty cool stuff for alpha software :slight_smile: I tried to increase the image size by adding a lot of zeroes to the image file. That works, ideinfo now says that I have 200 GB on my virtual harddisk.

But how can I make Haiku to make use of it? I tried chkbfs, to no avail because the command is not available. Same goes for fdisk, drivesetup or other disk tools. Where can I cat them for my factory produced image?

Increasing the filesize of an image doesn’t magically make the filesystem on it larger as well - it only increases the “partition size”.

There are no “resizing” tools for BFS that I know of - you’ll probably have to format a new image using R5 or Zeta - or use the Haiku build tools to create one of a larger size. You might be able to find someone willing to create one for you and send it.

Thanks, now I know in which direction to look. Maybe I better wait until Haiku hits a beta release. Filesystem tools are quite important to have, IMHO.

I’ve finally found the problem with the partitions and got already BeOS working.

  • The problem with the large disk is just that it doesn’t seem to be recognized by BeOS. No driver I suppose.
  • The problem with the small was a bit strange… Probably caused by the mandrake installer:
    ** The extended partition was the 3rd (in linux hda3) and the first logical partition was 4th (in linux hda4). This made most partitioning programs (and BeOS system) think that hda4 was a physical partition and gave the partition table as corrupted because they founded that both third and fourth partitions were overlapping…
    The solution to this was simply making sure that logic partitions start at 5.
    Thanks to all people that tried to help.

Great to hear that you figured out the partition issue and thanks for sharing the solution.

BeOS was limited to 137GB drive size.

Haiku/Zeta do not have this drive limitation.