No icons in GTK applications/pixbuf issue

Hello everyone,

So, I recently installed GIMP- it worked great at first, as did other GTK applications. After a bit of playing around with it for a couple of days, I went to open it and none of the icons load. Starting it from the Terminal gives a slew of warnings, like any GTK application on any platform might. But I began to notice:

Error loading '/packages/mypaint_brushes-1.3.1-1/.self/data/mypaint-data/1.0/brushes/tanda/watercolor-02-water.myb: Couldn't recognize the image file format for file "/packages/mypaint_brushes-1.3.1-1/.self/data/mypaint-data/1.0/brushes/tanda/watercolor-02-water_prev.png"

…for what appears to be all of the icons. I also noticed the following, which appear to be GIMP reacting to this issue:

(GIMP:23540): Gtk-WARNING **: 15:51:07.225: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.

So, I quit messing with it. The application is still mostly functional, albeit not very useful without icons.

I had some plans to mess with porting/building gnumeric from source. Once I had it running, I noticed it also had no icons. Running back through the scrollback on the terminal, I noticed something similar was happening:

(gnumeric:23606): Gtk-WARNING **: 15:55:17.179: Error loading theme icon 'gtk-cancel' for stock: Failed to load /boot/system/data/icons/haiku/actions/32/gtk-cancel.svg: Unrecognized image file format

I also had interest in getting abiword running, and since it is also GTK, I had my hypothesis and confirmed it:

(abiword:23642): WARNING **: 15:57:31.908: Unable to load Abiword icon /boot/system/non-packaged/share/icons/hicolor/16x16/apps/abiword.png: Couldn't recognize the file format for file "/boot/system/non-packaged/share/icons/hicolor/16x16/apps/abiword.png

In this case, abiword does not even get as far as drawing the window before being killed. I cannot be sure (easily) whether this is just an issue of a fresh port that I need to dig into, but perhaps it’s related. I can do a log or a dump on it if it helps anyone.

TL;DR: Is this a pixbuf issue? I understand exactly 0 about how GTK/glib/pixbuf/gdk, etc work. I have tried “gtk-pixbuf-query-loaders --update-cache” with no results. I’ve also verified that there are (definitions? translators?) in loaders.cache.

Kinda stumped here! I can provide whatever debug information y’all might need. I didn’t open a ticket since I wasn’t sure if it was something I had broken unknowingly, but I can if needed.

  1. Try to remove /boot/home/config/non-packaged/data/mime directory if exist
  2. Package shared_mime_info installed?
1 Like

Deleting (rather, moving) the mime directory worked to restore my icons. shared_mime_info was installed already. There’s some cursor corruption but otherwise it works great, now.

I’m curious now, does deleting the directory force it to regenerate mime information? I opened gnumeric directly after moving it and it worked great. Thank you so much!

The glib issue is in the mime database lookup function. If it finds it somewhere else, then it doesn’t try to look further in /boot/system/data/mime

1 Like

Having the same issues, thought it was about missing icon themes with CodeBlocks and Geany.
Geany launches but showing no icons:

CodeBlocks from sf-mirror, launches but crashes right after that:

I tried fidling around with the Adwaita icon theme but couldn’t get any further.

PS, no ~/config/non-packaged/data/mime and shared-mimi-info is installed


Wow nice work, i tried to port some weeks ago and i can comply but i never been able to run it
Geany is a nice IDE

You have the wrong path to the icons. Look at the log in the terminal. There is no /org/gtk path in haiku


I know, but can’t figure out where to change this?

EDIT fiddled a bit more with the recipe and in the process of making the UI using Noto fonts, WebPositive as default browser … getting there. :slight_smile:
PS one can also set the toolbar to just use text instead of icons in preferences. :slight_smile: