Nightly: su requires a full pty


#1

su user -c "..." used to work well in alpha 4, such as over ssh, for running privileged commands. Now in nightly, su requires a full pseudo terminal environment or else exits with a message like:

su: Refused login. Setting up environment failed: Invalid Argument

This is annoying. As a workaround, Packer can synthesize a pty with ssh_pty: true, though is is not ideal.


#2

Noticed this by chance and so fixed it in hrev52300. In the future, if you don’t want these to get lost, please open tickets on the bugtracker.