Nightly (64bit): "Updates did not complete"

Hi awesome Haiku dev and user community - I"m using Haiku 64bit nightly in a VM hrev56595 - when I run the software updater I get this error:
“failed to commit transactions: Failed to change the package activation in packagefs: Name in use”

Please help


Among packages that are causing problems: adwaita_icon_theme, gcr, libhandy, wailand and all gstreamer packages. If you have a notch in case Show more details, you can see that these packages have same exact version. However they seem to have changed (different date or checksum after rebuild?) and SoftwareUpdater wants to upgrade them. Probably their package version wasn’t bumped so it ends up with the above message. Doing a pkgman full-sync leads to same problem.
Meanwhile, you can use pkgman update package1 package2 … in terminal for packages that needs to be updated. I.e. those that have a newer version.

As a side note, you shouldn’t use Flat decorator/ control look at the moment, to avoid these holes between borders and windows. The hole in repository window ( above + and - buttons) is present with all control look when you raise font size and should be fixed. I don’t know if there is a bug report for that already.

I think nightlies have moved to r1beta4, so you need to change or add both repositories for haiku and haikuports (just change master to r1beta4 for both).

HaikuPorts now has WebKit_GTK, Wayland_protocols and other popular packages. Perhaps your other repos have versions of the same packages, causing a namespace collision.

1 Like

webkit_gtk package failed to build so it’s not in HaikuPorts repo yet.

Maybe not, but some of its dependencies are.

I had to try 3 times to upgrade!

The two recipes have just been updated by @3dEyes on HaikuPorts. Once the buildbot runs it will be fixed.

1 Like

I had the exact same error on one of my Haiku boxes. Manually removing the following packages from /boot/system/packages, and then reinstalling them through HaikuDepot fixed the issue.


So my primary desktop PC is working fine after this (including Epiphany). However, on my laptop I never encountered these issues, but Epiphany after this mornings update crashes on start (assertion in gtk_icon_helper). So something is corrupted between LOTE and haiku_ports since both systems are up to date (and Epiphany worked on both systems until this mornings update)

And thanks to Gerasim (3deyes) amazing response time, Epiphany (and GIMP) now also work without issues on this laptop. A post install script for some reason never got applied on the laptop. (gdk_pixbuf). All is good now (posting from Epiphany on the laptop)


Hi @Zenja - Epiphany and GIMP now crash (Epiphany immediately and GIMP after the splash screen messages).

Any ideas how I can get them working?


  1. remove (if exist) /boot/system/non-packaged/data/mime and /boot/home/config/non-packaged/data/mime folders
  2. run postinstall script /boot/system/boot/post-install/

Awesome! Thank you @3dEyes ! - that worked - GIMP and Epiphany working great (again)