New to Haiku and having a couple of problems

Ok, so I am installing Haiku (have tried both r3 and nightly) onto a drive all by itself. I do the drive prep as the docs say and all goes good right until after the reboot to boot from the drive. When it tries to boot I get an error saying “error booting from operating system” So I then boot from the cd using boot manager and change to the Haiku drive and it will boot into it no problem.

So here is where something weirder happens. I have used the keyboard to do the “hold shift” to get into the boot manager and the selected and entered to change to the Haiku drive but now that it has booted I have NO keyboard. Argh. I have tried 2 x PS2 keyboards and a usb keyboard same results. I have gone into the keyboard and keymap prefs and in the keyboard test area no go. Ok for sh*ts and giggles before I sent this msg I went out and bought a new cheapo usb keyboard same results…aargh

SO here’s is where I am at. I need to get a keyboard working so that I can run boot manager in the terminal window so I can get Haiku to boot completely from the boot drive so I can get to trying it out. (yup that is one ugly long sentence)

Any help appreciated. Thanx in advance.


you can run Bootmanager via the installer,by clicking on tools >>set up a boot menu.

Thanx khallebal for the suggestion. I should have come back here and updated my message. I had already gone and run the boot manager from the apps and got it to set up a boot menu. Works great now.

As to the other problem, got that fixed also. I went into devices and noticed I have a quite a few unknown devices. So I unplugged the keyboard and did a refresh of devices. Nothing seemed to change so I plugged the keyboard back in and now it works. Damned if I know what the heck changed, but I am a happy camper now as I have a running system with a working keyboard. I will be working on figuring what the unknown devices are and see if there are drivers for what is missing.

So now to learn Haiku as much as I can. I am not a developer but if I can help test something for someone just let me know. I have been an IT consultant for 17yrs so I can usually figure stuff out and I don’t mind redoing my system as needed. The system I have now will be dedicated to Haiku.

I do see the need for Haiku to set up the boot manager on the hard drive if it does not detect any other partitions than the Haiku one. I should not have had to go and run boot manager and make a boot menu after I had just done a fresh install. Just my 2 cents worth…

Have a gooder

Sounds similar to my situation
Could you attach your syslog to this ticket?

Also you can safely ignore unknown devices, that only means that it’s not in the PCI ID database .

You had to install bootmanager because your MBR was broken (an old grub?) or because our bootable primary partition is not flagged “Active”…

There was no MBR as the drive was a clean drive when I started. Nothing else on the drive. I marked the drive as active when I set it up with the installer partition software that you have to do when you have a clean drive. The drive was setup/initialized for BeOS. I wanted the drive just to have Haiku on it so that I didn’t have to fight any other issues while working with a new OS. (LOL I don’t need any help screwing things up, I can do that myself and I am getting good at it too)

I am going to redo it from scratch again and see what happens. See if I missed something or if it happens the same way again.

Well redid the drive using 44190 nightly and it works like it is suppose too. Must have been something I did when I did it the first time. Well onward using the system…

I am going to redo the drive again, so I expect it will happen again. I will attach the syslog from that one.

Thanx for the heads up about the PCI ID’s. Hmm someone should maybe update the list Haiku uses then. As that file is up to date. (Damn, I wish I had learned more programming)

Well, seeing no partition on the drive doesn’t mean the drive is empty. Did you have to create an Intel partitioning map ? if not, your drive was not empty. Haiku never overwrite the MBR boot code area if an existing partitioning map exists (i.e. if the first sector is not completely zeroed).

If you want to install a standard MBR, You have to use a 3rd party tool.

  1. Boot Haiku
  2. download and extract
  3. run
    ./ /dev/disk/ata/0/master/raw
    (note: adapt the device path to your configuration)

NB: a ticket is already opened for this issue :

Hey there, yes I would have also had to make an Intel partition. The reason I know the drive was empty was because I wiped the drive clean with software. I am a IT Consultant and so I get old equipment that some of the companies I do work for don’t want any more. But they want me to make sure there is none of their data on it. Having a program write 1’s and 0’s to the complete drive a few times gets rid of everything nicely.

Thanx for the help/suggestions though. I went back and recleaned the drive and did the install from scratch from the 44190 nightly and followed the same instructions again and it works like it is suppose too. So I mucked up some where on the first go round.

Now I have to find out why Webpositive is not part of the nightly or if it is where it is hiding. There was no icon for it in apps and when I go to read the help docs all that happens is it opens the .html in a text editor, But for me this is part of the reason I am trying out Haiku, I like trying to see if anything has errors or is broke. If I figure out there is an actual error/problem (NOT one that I did myself…like this one) I can make a bug ticket on it, where another person may just think Haiku is junk and stop trying to use it. I can’t write code but I can help find the bugs in someone else’s.

Webpositive is not part of the nightly builds in order to keep the size down. These builds are primarily for regression testing and only contain a subset of applications. You can install it with the “installoptionalpackage” command.

Thanks. I should have realized that.