New First Time Install

I finally got brave enough to try to install Haiku OS on a computer. I’m an inveterate distrohopper in Linux systems.
I downloaded the file. Nothing was said as to how to unzip the file. Apparently gunzip doesn’t do it, and I had to learn to put quotes around the filename. But I got that.
No problem burning the DVD.
Then I learned my System76 Kudu3 could not boot from DVD.
So I got out an old IdeaPad 110.
Then I learned, through kernel panic, that the installation disk could not create its own partition. So I got out my GPartEd 1.0 disk and created a partition.
And now I discover that it cannot recognize an unformatted partition, and I cannot find how I should format it. (Ext4, fat, or what.)

So this is where I sit. Can anyone get me past this point?

i found that if your hardware is supported the installation is pretty straightforward…https://www.haiku-os.org/get-haiku/installation-guide/
maybe you can try first on virtualbox before installing on phisical machine…

There have been a lot of holes in the installation guide just getting to this point, as mentioned in my post. I followed that guide this far.

But the Installation Guide just says to create a partition. It does not say to format it, or what format to use. I have created the partition and left it unformatted. I rebooted with the Haiku OS DVD, and got to the same point, a kernel panic.

I didn’t see a list of supported hardware. Perhaps that is where I’m going wrong, assuming I can put it on anything I have.

The Kudu 3 would not work, because it would not boot from CD. That’s OK.

My next step is a Lenovo IdeaPad 110 with AMD chips. That is what I’m trying now. I do have a Lenovo ThinkPad T430 I could break out of a box… I’m trying to sell that one (and the IdeaPad for that matter, but I’ve already posted the T430 for sale and not the IdeaPad)… Otherwise, I do not have any more hardware to try it on other than my Galago Pro 2, which is also likely to not boot from CD, but I guess I could burn the software to a USB stick and try again.

…it seem initializing word is same with format…cmiiw initialize with befs

If you are using the beta, you should definitively switch to the nightly image.
Also you can use a USB key to install haiku.

Hi Zaivala!

Good point. We’ll add that to the download page.

AFAIK “gunzip” is used for gzipped (.gz) archives. “unzip” should work, even without quotes, as the Haiku image archive name has no spaces.

That kernel panic can be investigated when there’s a ticket at our Trac.
The installation guide does mention to create a partition under “Preparing a Partition for Haiku” and how to format it with DriveSetup with step 6 ff.

Did you follow a different installation guide? If so, do you have a link so we can remove/improve it?

I did try unzip without quotes on the filename and got an error. Sadly, I do not remember the error wording (no photographic memory here). But at least when I found a place which said to use quotes, I did and it worked. I did not even know I had “unzip” because everythig I use in Linux calls for “gunzip” so I tried that first. I don’t know everything. I have no IT training, just have been playing with OSes for a very long time. Sometimes that means I learn the wrong lesson.

The installation guide I found told me that the installer could not create its own partition, but did not sy anything about how to do that other than to use GPartEd, and I already had a disc for that… but did not say anything I could see about preparing the partition, I will go look at what you sent and see whether it was my stupidity or a lack of information.

I tend to not create tickets until I can’t get help for a problem. It could always just be me being stupid.

A Alternative install guide is here:

http://old.besly.de/menu/search/archiv/sys/haiku_installation_eng.html

Hardware lists:

https://dev.haiku-os.org/wiki/HardwareInfo

http://old.besly.de/menu/search/archiv/misc/haiku-hardware_compatibility_list.html

https://sites.google.com/view/hardware-list-for-haiku

The haiku guides are very good, better like many other one. Who does a great job.

The problem you have is, that you think to need format a disk with bfs. Bfs is not to Format, it will be inizialised to a available partition (ext2, fast…)