Network not working in virtualbox [solved]

Hi, I love the Os and I want to be involved in everything I can…

For now I have installed it in virtual box it runs good.
But networking is not working, debugging from the network preference is done but without network is difficult for me to export anywhere the text…

I’m running it on virtualbox 3.06 under ubuntu linux with kde session as Other/Unknown OS.

I’ve solved while writing this post… I only had to change the network driver to intel…

I post this thread in case it could be useful for someone else.

It worked!

VirtualBox 3.0.10 on OS X 10.6 host. Oddly my RTL81?? gigabit card which works as AMD PCI II in VBox for a ubuntu guest did not work. So I followed this suggestion and switched to Intel and here I am!

This is looking very promising already!

I installed the Haiku alpha release on VM Fusion 2.0.6 on an Intel MacPro. The Fusion internet setting is “share the Mac’s internet connection”, with network setting DHCP in Haiku. The Mac is set to “share internet connection”. But I cannot access the internet from Haiku. My Mac is on a LAN with a wired LinkSys router. Any ideas would be appreciated. (I used to use the BeOS 10 years ago and loved it).

Hi KantosKan.
I have neither Mac nor Fusion, but maybe Zenja’s post can help you.

Hi Humdinger,
Thanks for your suggestion. I tried everything in Zenja’s post and related posts, but it still doesn’t work. I also upgraded Fusion to 3.0.1. The Haiku network status thinks it has a connection, but I can’t ping anything.

Thank you Humdinger and Zenja! The network is now working. The solution: set networking to NAT in Fusion. Set the Mac’s sharing preference to “share internet connection”. Set Haiku’s network preference to DHCP. Let it choose the ip number, gateway, and mask. Then change Haiku’s network method to “static”. Leave the ip number, gateway and mask unchanged. But change the DNS numbers to those in the Mac’s network preferences. The internet then works !
(OSX 10.5.8, Fusion 3.0.1, Haiku alphar1).

Well, that was easy… NOT! :slight_smile:
I’m glad you were successful at last.