»nervous« harddrive

… sorry, another post (today is haiku-day :slight_smile:

in my ibm x31 the harddisk is starting and slows down in very short intervals.
the drive is like new and working perfectly, but often haiku is waiting some ticks
for the drive. it spins down and up every 5-10 seconds.
i’ve visited the bios-setup (not quite familiar with it, as mac-user), but even the
high-performance-setting changed anything.
does haiku have energy-settings? i don’t think so, right?

thank you

You say the drive is “working perfectly” and yet you describe symptoms of horrible drive failure, very likely meaning imminent loss of all data on the drive. Can you explain what “working perfectly” means in this kind of situation to you ?

In any case, you should run good disk diagnostic software. If it’s the built-in disk of the laptop, not an external USB drive or something like that, then you can do this from a suitable Live Linux distro, or from Windows if you have that. Use a different machine to read about how to interpret the diagnostics. The drive firmware will spin down and try to restart a disk when it detects some types of faults, and unless it’s an external drive with dubious power supply this is by far the most common cause of such behaviour. If there is any data on that drive you’d be sorry to lose, back it up immediately.

In fact, if you’re someone other than “stoltenberg” reading this and thinking “My drives are working just fine” then remember at any time you may find you have one less copy of everything than you thought you had, starting five minutes ago. If that worries you, take more backups.

thanks a lot for your advise, but i’m pretty sure, that is no hardware-error of the drive.
after scanning the web, i found many threads regarding the aggressive energy-safe-functions of this harddrive.
it seems to be the head, which is parking just a few seconds after the last read- or write-action.
now i’m trying to mount the disk in an external enclosure and try some tools …
p.s.: is there a reliable backup-solution for haiku?

I’m not aware of any tools to adjust this in Haiku. Linux has hdparm which can change the time before the drive will park heads and go to idle mode. I’m not very surprised the setting is low on IBM laptops: the laptop may be moved at any time and it is not a very good idea to do so while the drive is spinning, so they made it go to sleep when it is idle, as soon as possible.