Mouse won't work and partition problem


#1

Hi,

I have tried to install Haiku for the first time. First of all, I had to go for Alpha 3 because Alpha 4 always got stuck.

Now it works as far as the first screen. First of all: the mouse won’t work. Somewhere else on this forum I read that could have something to do with the resolution. By pushing the space button during start-up, it should go in a mode where I could adjust the resolution, 800 X 600, 16bit was suggested. Holding down that space bar just
didn’t have any effect,…

I couldn’t choose a language on that first screen, but with the arrows I could go in installation mode. There was stated there were no suitable partitions found. “Making” a “Be”-partition was required…!?!

I have enough empty partitions on that HDD and probably could work around that but…
first of all : That little hand that calls itself a mouse must work!!.. :angry:

Any suggestion how to fix this?

Thanks in advance for any reaction and greetings from Belgium!!


#2

i’m suggest you to try nightly build…


#3

Mazbrili, thanks for your fast reaction!!

Sorry, I didn’t mention that, I also tried 2 different nightlies but no go, not even a first Haiku screen.

Is there something special I maybe must pay attention to, installing these nightlies?
Why are they called nightlies anyway…?


#4

You definetly not want Alpha3/4.
But you definetly needs to give more info about the hw.


#5

I presume by hw you mean hardware?


Description of my computer:

Operating System
Windows 10 Pro 64-bit
CPU
AMD A10-7860K 107 °C
Godavari 28nm Technology
RAM
8,00GB Single-Channel DDR3 @ 798MHz (10-10-10-30)
Motherboard
ASRock FM2A78M-HD+ R2.0 (CPUSocket) 53 °C
Graphics
U28E590 (2560x1440@29Hz)
1024MB ATI AMD Radeon R7 Graphics (ASRock) 56 °C
Storage
465GB TOSHIBA DT01ACA050 ATA Device (SATA) 34 °C
698GB Crucial_CT750MX300SSD1 (SSD) 37 °C
256GB Crucial_CT275MX300SSD1 (SSD) 37 °C
931GB Seagate ST310003 33AS USB Device (USB)
Optical Drives
ATAPI iHAS124 F
Audio
Realtek High Definition Audio


The Toshiba drive has Linux Mint on it and also has 2 empty partitions.

I hope this is the info you meant by “hw”…


#6

They are called “nighly builds” because a new one is built every night (or every day, if you are not in the same timezone as the server).

There is nothing special, just put them on a CD or on an USB stick (using dd or some similar tool) and you should be good to go.


#7

Hi,

when you press the Space bar and you the menu, go into >>> Select safe mode Options <<< and set
the >> Safe mode <<< and >>> Use fail-safe graphics Driver <<<. If you have luck, you can use Haiku and install it on the Harddisk.

you can test folling Option in the safe mode Options.

Don’t call the BIOS

Disable APM

Disable ACPI

I hope you have luck.

Regards lorglas


#8

@PulkoMandy : Putting it on a stick and starting Haiku is not the problem. The problem is that the mouse freezes every time, so I can’t get in the setup procedure…

The last one I tried was Nightly 52139, Haiku started but gave immediately error codes starting with:
Panic: “Didn’t find any boot partitions” and that followed by a lot of numbers…(This I only have with the nightlies)

@lorglas As I mentioned : pressing the space bar has no effect at all!!

Another question : should I maybe try with the raw image files and if so, how do I process them to do it right?

Miqlas wrote I shouldn’t us Alpha 3 or 4. So in the meanwhile I’ll try 2…That’s already 8 years old…Getting a bit desperate here…

Hopefully with all your help, it’ll work somehow


#9

Trying alpha 4 or anything older is useless. We can’t help you debug these except with “try a recent nightly”. They are not supported anymore. Forget about them.

Ok, this is more precise already. It means you managed to get past the bootloader and into the kernel already. Is this running from an USB drive or from a CD? If it is USB, did you use an USB3 port? Does the machine have an USB2 port or does it allow to disable xHCI in the BIOS and switch all ports into USB2 mode?

In the alphas we did not have support for USB3 at all, which would explain why your mouse did not work. In the nighlies, there is some support, but there are some bugs left too. It should be enough to get a mouse moving, still.

You can try the raw image directly on an USB drive, but I don’t think it will work better in this case (the only change is there is no partition table, which may make the BIOS skip some boot steps)


#10

Regarding the “Didn’t find any boot partitions” message, you can try going into your BIOS and changing the boot mode from “UEFI” to “Legacy” and enable CSM for everything it allows.

Or, an easier way, is to use this image (without changing boot mode or enabling CSM):
https://keybase.pub/kallisti5/haiku-nightly-anyboot-efi.iso


#11

I use a rewritable DVD. I checked and all USB’s are in USB2.
I didn’t find anything named xHCI.

Meanwhile I’ll try with the raw image.


#12

It seems that the communication between the system board and the user interface devices (keyboard and mouse) is mixed-up with the boot loader.

Not being able to entering safe mode by pressing the space bar within the boot loader is most puzzling. Worst is that it seems to be observed with all releases tried - Alpha 3, Alpha 4.1, HRev 52139, etc.

Is your keyboard wired or wireless?

Is your mouse wired or wireless?


#13

Both mouse and keyboard are wired.


#14

Try SHIFT instead. Hitting the spacebar often only works when precisely timed; you can keep holding SHIFT right after the BIOS post.


#15

You may have encountered bugs!

Keyboard:
In the Windows world, there are a number of reports of keys, often the Space Bar key, not working. In most cases, the key mapping matrix internal to the keyboard does not match that of the device driver. Multilingual keyboards were explicitly mentioned in a few of the reported cases.
Some of the key combinations which got the Space Bar key to work are Caps Lock, Fn, and Shift. I did not see a mention of Alt or Ctrl; would still be worth to try if Caps Lock and Fn do not get the Space Bar to work under Haiku.

Mouse:
There is an old ticket ( https://dev.haiku-os.org/ticket/9414 ) about a specific Logitech mouse not working in Haiku and yet being perfectly fine under Windows and all Linux distributions tried. Using a different Logitech mouse resolved the issue for that user.
The ticket is still open indicating that the issue may still be present, or may have been indirectly resolved in later revisions and the solution was not tested.


#16

The mouse was the cause !! I, indeed had a Logitech mouse and replaced it with another one and I could make the right partition and install Haiku. But it wouldn’t work with the nightly, same error messages as I mentioned before.

So now Alpha 3 is installed but now I have to “address” it right. In Windows I use EasyBCD to make the boot menu. Now I don’t know what the right “instructions” are to get it to boot from the Haiku-disk.

As “type” I have to go for Linux/BSD because the only other option is Windows.

And then I have to choose the “Grub” or otherwise: Grub(legacy), Grub2, Lilo:eLILO, Free BSD, Wubi and SysLinux.

I think I have to do this with “trial and error” unless anyone of you knows the right things to instruct.


#17

Excellent that the issue with the mouse has been clarified.

It would be helpful to the community if you were providing some details about the Logitech mouse which was not working. At the very least having the model number would prevent future exploring users with the same mouse to give up on installing and using Haiku. Also, whatever you do, don’t throw out this mouse as your help may be necessary to test any patch aiming at resolving the issue!

How about the keyboard? Have you been able to enter Safe Mode with Space Bar in combination with some other key?

As for proceeding further with the installation of Haiku, you may avoid a long trial and error process by consulting the Installation Guide ( https://www.haiku-os.org/get-haiku/installation-guide/ ). There are instructions for getting Grub to chain load Haiku.

Good luck.


#18

Mate, if nothing helps use the current nightly in virtual machine. Nobody can be enough masochistic to use Alpha 3 in 2018.


#19

@Stacked_Lambda First of all: the crooked mouse!! It’s a Logitech optical mouse of which I obviously have no box anymore. But some wandering in the Logitech dungeons finally got the mous out of the little hole: it’s the corded USB-connected Logitech M500… this one!!

And here you can actually see the animal move

About the keyboard, no luck there: keeping the shift down straight after Bios while booting doesn’t do anything.
But in the installation guide I read that once you manage to get the boot menu up, you can go in safe mode.
But typing already worked fine, naming my disk partitions while setting up, for example.

@miqlas What I have seen in Alpha3 indeed doesn’t give much confidence in an OS. And that’s just the point: Since about 3 months I’ve been trying out/testing some open source OS’s except for the real Linux distro’s. I’m a Linux Mint fan for many years…(every man his hobby…“whatever makes you tick” is the English expression, no?) On the other side of this all, I am also a Windows Insider which was most interesting when they started to develop W10.

It didn’t even have a name back then (2014?), they just called it Treshold which became Redstone later. It was interesting because they (almost)started from scratch within the Windoze environment. The first insider preview version had a screen with only the dustbin prominently in the left upper corner.
Configuration screen was still there but much more basic, etc…

But then they were putting in software and functions which we had to take to the test and give feedback on. And guess, sometimes they actually listened!! I am proud to say that I, among others, have improved the structure of bookmarks in Microsoft Edge…

Say what you want about Mickeysoft but they did a good job on this one: a test bank with about 3,000,000 testers giving constant feedback(and actually getting personal answers from developers, which kept them motivated). Not only testing but also they constantly could “feel” what the people expected from W10.
I remember a group discussion about the 3D drawing program they wanted to implement(became Paint 3D afterwards). There were people who already had experience with putting 3D “things” on a screen. “They stated: Microsoft, don’t put time and money in it, FREE third party apps are already better at this moment.”
They listened it’s become a very basic program, nothing more.

But back to Haiku: Alpha3 reminds me of Windows 3.1(for those of you who really had to work with that…
And Miqlas, masochistic is the word…

What I am going to try today is:

1/ First of all: format the partition with Alpha3 on it
2/ I am going to try the nightlies again from top to bottom, one should work, no?
3/ If not so, I am going to my little Virtual Box and look at it there…are there some
very recent screenshots of Haiku? So I can see what I am putting time and effort in…

Thanks all and I’ll keep you posted!!


#20

The look did not change all that much since alpha 3. But the OS should work much better and come with a lot more applications.
Screenshots: https://www.haiku-os.org/slideshows/haiku-1/