Mouse locks up,can do nothing

I just got Haiku to work for the first time from my HDD this morning.
I was able to get the computer to go to Google on the WWW and the USB Corded mouse locks up every single time.
I cannot free the computer with any key stroke I know.
I have to do a hard shut down / re-boot to get the computer running again.
It will lock up every time I try to go to the internet off of Haiku.
Any ideas?

It’s gotten worse. Now once the computer is up and running, if I move the mouse anywhere on the screen the computer locks up hard. Nothing can be done.
I have to do a hard shut down in order to get the computer to do anything.

Not sure what’s happening there. Is the mouse plugged into a USB 2 or 3 port?

I’ve tried two mice. One USB one old fashioned green pin plug.
Now the computer is locking up when ever it feels like it.

I need to figure out how to do an update. Maybe that will help?

EVERY time I type into the address bar of WebPositive to go to a new location out of Haiku the computer locks up. NOTHING can be done. As in, N O T H I N G other than hold the power button down for several seconds and crash the computer.


Are you running beta instead of nightly? There was a problem with xhci driver which caused this exact issue in the r1beta, and got fixed by Augustin after the beta was released. Try a nightly image and the problem should disappear.

This is maybe your Wifi drivers card. I have something similar with my Atheros Wifi card. Nightly build do nothing for me about this trouble. My system freeze when I enable Wifi and attempt to connect online by any application that use network. I must use an ethernet connection cable for it to have a stable system.
Try disable Wifi and let the system run sometimes for view if this is that…Uper right corner to configure the Wifi.

Well hell. I tried two other brand new wifi cards and it wont even see them!
I put the original back in and now there is no “WiFi” little weird icon, its gone!
no way to load drivers it wont see the CD software.
I’m boned.

Maybe in the preference menu>network for see again your wifi card but if you activate it the system will be freeze again I think.
If you talk about the drivers of your wifi card CD that are certainly not compatible with Haiku for now. Usually manufacturer drivers are for Windows/Mac and maybe Linux… You can try the Haiku nightly image, and reinstall this Haiku iso maybe there is an updatef for your card on it.

For my atheros card that doesn’t work. I have did a network with Ethernet cable to go online with Haiku.

I can only access the internet via a wireless LAN of my home and shop. There is no practical way to use a cable system.