Mouse/keyboard doesn't work in live cd

I got the live cd to boot (finally!) but now, when the hand appears and there is a dialog asking for desktop or installer, neither the mouse or keyboard works. I’m using a usb wireless logitech mouse and keyboard, but I also tested it with a PS2 mouse and keyboard with no luck! Has anybody had this problem before who can help me with this?

Let me know what extra info you need.
I’m using the disable IDE DMA (or something like that) option along with safe-mode display at 1024x768.
Thank you.

I could understand some USB devices not working, but it does seem very strange that PS/2 devices don’t. I would check your BIOS to make sure their aren’t some strange settings. For example maybe the PS/2 ports are disabled.

Also for the USB devices see if any strange settings are on for USB. I believe it is recommended to turn off the plug and play OS setting if you have that. And you may want to experiment with any options related to USB input devices (for example turn on or turn off legacy or emulation mode.)

Well, I have the same problem and the BIOS of my laptop (Dell Studio 1555) doesn’t have anything to setup the keyboard or mouse.

An external USB mouse works, though.

I have the same problem with Microsoft wireless keyboard and mouse. The keyboard works for making changes in the system’s BIOS but not when booted to the Haiku live CD.

I have the same problem with my usb keyboard. Diver said he had the same problem with a PS/2 keyboard. I ended up unplugging the keyboard and moving it to another usb port while everything was still running and it started to work.

I redid my setup completely and still had to move the usb keyboard to another port, even though it had worked just minutes before on the old setup.

Another weird thing is that my usb mouse has always worked right from the get go. No having to move ports or anything. So why just the keyboard for me?