Missing symbols and serial port

Hi after a long absense I’ve returned to the BeOS opps! Haiku with Alpha3 and I’ve been attempting to install my favourite software. I’ve copied Gobe Productive over from my old Zeta 1.2 disk (yes I do have a seperate license) and I’m pleased to say that that it works. However, I’ve just tried to install personal assistant and get the message “Could not open Personal Assistant (Missing symbol:_12BMailMessage)” - get the same message attempting to open BePlan. (Similarly I when I attempt to open BeatWare writer (which worked on R5) I get another missing symbol message _free).
I’ve also attempted to sync with my old Treo 600 through the serial port but when I use Palm reflections I get no serial port number. Does A3 have a serial port driver?

Any practical help to get some of these old favourites working would be greatly appreciated.

Best regards BeJay

Pretty much any time that you get a “Missing symbol” type message, it means that either a required lib is missing or is the wrong version.

I wasn’t familiar with Personal Assistant, so I looked it up at Haikuware and downloaded it. Sure enough, the “BMailMessage” symbol is missing. It should have gotten that from libmail.so (in /boot/system/lib). Apparently, there was a recent change to the mail stuff where a new class, BEmailMessage, was implemented to take over that functionality. Nevertheless, the old BMailMessage interface is supposed to be there, from what I can tell. And yet, it is nowhere to be found in libmail.so (at least not according to objdump).

This is likely a bug, and a ticket should be opened for it.

Out of curiosity, I tried an older libmail.so and this worked. I had an older image file laying around (r36974 – which is an r1a2 version from Jan 2011) and replaced the current libmail.so with the older one. This DID work… well sort of. It would allow Personal Assistant to start up (you get to the main screen). But from there, you can’t do anything else. The interface is just locked up and won’t even repaint if you resize the window. Had to kill it from Terminal.

In other words, even with a corrected libmail.so, the program just isn’t usable. Either Haiku has introduced some subtle binary incompatibility, or Personal Assistant is one of those “bad” old apps that makes use of BeOS internal APIs.