Missing libraries for running Softmaker Office

I have used Puppy Linux for years on my netbook.
Now, while preparing a separate partition for installing Haiku, I ruined linux partition, by mistake (my wife distracted me in critical moment:-).
Therefore, now I have Haiku only on the computer and I want to give Haiku chance to become my primary OS.
One thing preventing me to do that is lack of an office suite.

Since I have a licence for Softmaker’s Office 2010 suite for Linux, I tried to install it.
Apparently, installer installed the suite in my /boot/home/office2010 folder but executables can’t be started, because the following libraries are missing:


Is there a way to find these missing libraries, for Haiku?

Thank you in advance.

you might want to compile them… linux software don’t run on haiku AFAIK.

Installing libraries from haikuware ports solved some of the listed missing libraries:

But, the following libraries are still missing:


Where to find these?

http://haikuware.ru/get/files/office/TFO4Installer-0.1a.sh.zip ThinkFreeOffice 4.0 for Haiku


You will need source code to recompile, because Haiku uses a different kernel than Linux. Also, Haiku uses a different GUI than Linux, so unless Softmaker Office is written for Qt or X, the interface would need to be rewritten.

But in answer to your question, if linking with GNU C/C++, libm and libc are in libroot, and here is a version of libdl:

[quote=AndrewZ]But in answer to your question, if linking with GNU C/C++, libm and libc are in libroot, and here is a version of libdl:

The libdl functions are in libroot too.

libdl - Ah, OK.

I could have sworn that there was a build of X Windows for BeOS/Haiku, but I can’t seem to find it on Haikuware. Does anyone have info on X for Haiku? I know it sounds yucky but there is some pretty nice free X software.

Stop wasting your time, it’s not gonna work. Softmaker for Linux is a Linux software, as the name suggests. Haiku is not Linux. What you’re trying to achieve is like running Windows software on Linux or Mac OS X software on Windows. There is no X server for Haiku, but even if there was, the program wouldn’t run.

just do a search for “X11 beos”.

Damn, I tried with all X11 libraries packages available on haikuware.
None of them helped…

tatamata, as others told You, it won’t work.
You can provide every lib what required, but the binary what you try to run compiled for an another operating system. And because there is soo much difference under the hood between Haiku and Linux, it won’t work.

What You can do: send a mail to the Softmaker guys (but be nice!) and ask for a port. Maybe he will consider it as a good idea (but don’t live in a dreamworld, this guys also need money for life.

Thats all.