Make the system boot first

I personally tried many minor systems. I think Haiku is the most promising. I have plenty skill and time to contribute to this project. But, I never had be able to boot the haiku system from my real hardware though I could run it in the vmware. I don’t like run a system in vmware before I could write code for it. I think many guys have the same opinion. My computer can boot by windows, linux and some other systems. Why couldn’t I boot from Haiku? I couldn’t even catch the error message to send a report. It is really frustrating since I have kept my eyes on this project at the very beginning of the project. Is it possible some smart guy just copies the boot loader from linux? I couldn’t wait anymore to try this system in a real hardware.


A good start would be to explain what exactly happens when you try to boot Haiku and it fails (i.e., get a blank screen, system reboots, etc.). As a start, you could try the boot options described here:

Sometimes they make a difference.

Thanks a lot. I have read this post. So I hit the space.

For sure, I burned two discs. I also tried my two old computers. One is P4, the other is P3. Maybe the motherboards are two old? I just don’t know.

The only thing I got was that in the upper left corner of screen some strange color bars shew. I couldn’t get any other diagnostic message from the computers. I even couldn’t submit the bug report. So you know how frustrated I was.

So did you get into the Boot Loader options or did the computer just restart ?

If you can get into the Boot Loader options, then go into Select safe mode options, then tick/check “Use fail-safe video mode” and “Enable on screen debug output”, then go back to the main screen and select continue booting.

If you can not get into the Boot Loader options and the computer locks up, try randomly pressing the space button, or try pressing the space button while the computer is doing the Power On Self Test (POST) and keep holding it while haiku tries to boot (this is the only I can get into the Boot Loader options). You could also try a P/s2 keyboard if you are using a USB one, as haiku might not like it, or might be unable use it that early in the booting process.

Thank you richienyhus. I did use my English correctly. I used the word “have” other than “had”. I had already done as you said just after the alpha release. I held the space, I tried the ps/2 keyboard and mouse.

The only thing was some colorful bars in the upper left corner of the screen. No other response. I first want to report my hardware but I think it is not very meaningful.

If it doesn’t work its probably meaningful or a known bug.

You might look into building Haiku from the svn sources directly to a disk partition (I do this) to take the CD bootloader out of the picture

You can then use grub to chainload the partition just like windows since the build scripts make that partition bootable when building

The pretty bar of colours generally means Haiku doesn’t support that graphics card. I have the same problem on a PIII system. On my EeePC and Core2Duo desktop, i have virtually no problems.

My advice: try something more modern, or try a different graphics card. There might be deeper underlying problems, but at least that’s a start.

Haiku is alpha quality software for purely this reason :wink:

EDIT: I’d reccomend joining the haiku freenode channel (#haiku @ You might get more useful “live” advice there than in this forum.

My friends, thanks a lot. I never complain this for I know it is only an alpha. Basing on the man powers and stage, I would think Haiku already got a lot. That is the reason I think this project is superior to many other similar minor OS projects.

You are right. I think it is because that my hardware is so old. I checked the hardware compatibility list for Haiku. Most of the video cards they support are quite “new”.

But interesting, I found they support Geforce2 MX 200. I had one computer Geforce4 MX 400. I assumed this one is newer than Geforce2. But It got the same error. So I think Haiku only support the cards in the list.

Thanks again. At least I know the reason. It is really difficult for me to just find the card Haiku need. I had some new computers the cards are newer than those in the list. So that means I have to just wait for it.

If it appears to be booting then you should be able to get to safe mode and use VESA mode.

When booting, keep pressing spacebar - do not stop. You will enter safe mode and can choose VESA (fail-safe) graphics and video resolution.

If you press spacebar once or twice then you will miss because Haiku boots fast.

Haiku defaults to VESA mode for newer video cards without drivers and has drivers for older graphics cards.

Couple More Tips:
Alpha was a zip? Use your zip program to test integrity. When you burn, have your program verify the ISO on disk against the (burned) CDR version. Try different media, slower burn speed, different burner, etc.

I have the same problem. I burnt the installation CD, and tried to used it as LiveCD, to boot from it to test the system. Because boot failed, i have rebooted in debug mode(holding SHIFT) at the start and watched the numerous text of bootloader, most significant of which was - smth like -
"kernel panic - cant find bootable device"
somewhere in documentation I read that bootloader cant support two HD… I have 2 HD computer… but I m booting from CD and want to test Haiku only.
I must remove one HD and try to boot?

athlon xp 1700+, 1 GB ram, motherboard…forgot…but on VIA 266A chipset, graphics - GeForce 2 MMX 400.

I have two HD and can boot Haiku.

Hard to know exact issue but may relate to CD-ROM drive or other conflict.

Boot into safe mode (pressing spacebar while booting) and disable stuff to see if anything will get Haiku to boot for you. Turning off DMA and enable safe mode should let you boot I think.

Search here for similar reported issues (tickets):

This person had conflict with audio which caused Haiku to not boot.

no. it cant boot again. I ve tried different modes. and everytime it says - no bootable partitions found. as i said above - i burnt the last iso Haiku image to the CD, (because it is RW, i ve reburnt it again), but nothing changed.
Only one hint - I have 2 HD on first IDE channel and one CD drive as a master on second IDE(fromwhere I try to boot)…